summaryrefslogtreecommitdiffstats
path: root/dilos/dependencies/avahi-tqt/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'dilos/dependencies/avahi-tqt/debian/rules')
-rwxr-xr-xdilos/dependencies/avahi-tqt/debian/rules13
1 files changed, 10 insertions, 3 deletions
diff --git a/dilos/dependencies/avahi-tqt/debian/rules b/dilos/dependencies/avahi-tqt/debian/rules
index 5607222dc..0ecbf4f4d 100755
--- a/dilos/dependencies/avahi-tqt/debian/rules
+++ b/dilos/dependencies/avahi-tqt/debian/rules
@@ -8,6 +8,16 @@ include /usr/share/cdbs/1/class/cmake.mk
export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) -Wl,-z,defs
# -Wl,-O1
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
# Build options
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_SKIP_RPATH="OFF" \
@@ -17,6 +27,3 @@ DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_C_COMPILER=gcc \
-DLIB_SUFFIX="/$(DEB_HOST_MULTIARCH)" \
-DWITH_GCC_VISIBILITY="OFF"
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)