summaryrefslogtreecommitdiffstats
path: root/dilos/dependencies/tqt3/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'dilos/dependencies/tqt3/debian/rules')
-rwxr-xr-xdilos/dependencies/tqt3/debian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/dilos/dependencies/tqt3/debian/rules b/dilos/dependencies/tqt3/debian/rules
index 9d5ad6548..9b6c34f78 100755
--- a/dilos/dependencies/tqt3/debian/rules
+++ b/dilos/dependencies/tqt3/debian/rules
@@ -11,8 +11,15 @@ export LD_LIBRARY_PATH=$(QTDIR)/lib:$(OLD_LD_LIBRARY_PATH)
OLD_PATH := $(PATH)
export PATH=$(QTDIR)/bin:$(OLD_PATH)
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)