summaryrefslogtreecommitdiffstats
path: root/redhat/applications/bibletime/bibletime.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/bibletime/bibletime.spec')
-rw-r--r--redhat/applications/bibletime/bibletime.spec180
1 files changed, 0 insertions, 180 deletions
diff --git a/redhat/applications/bibletime/bibletime.spec b/redhat/applications/bibletime/bibletime.spec
deleted file mode 100644
index c33a47113..000000000
--- a/redhat/applications/bibletime/bibletime.spec
+++ /dev/null
@@ -1,180 +0,0 @@
-#
-# spec file for package bibletime (version R14)
-#
-# Copyright (c) 2014 Trinity Desktop Environment
-#
-# All modifications and additions to the file contributed by third parties
-# remain the property of their copyright owners, unless otherwise agreed
-# upon. The license for this file, and modifications and additions to the
-# file, is the same license as for the pristine package itself (unless the
-# license for the pristine package is not an Open Source License, in which
-# case the license is the MIT License). An "Open Source License" is a
-# license that conforms to the Open Source Definition (Version 1.9)
-# published by the Open Source Initiative.
-#
-# Please submit bugfixes or comments via http://www.trinitydesktop.org/
-#
-
-# Required for PCLinuxOS: removes the ldflag '--no-undefined'
-%if 0%{?pclinuxos}
-%define _disable_ld_no_undefined 1
-%endif
-
-# TDE variables
-%define tde_epoch 2
-%if "%{?tde_version}" == ""
-%define tde_version 14.0.9
-%endif
-%define tde_pkg bibletime
-%define tde_prefix /opt/trinity
-%define tde_bindir %{tde_prefix}/bin
-%define tde_datadir %{tde_prefix}/share
-%define tde_docdir %{tde_datadir}/doc
-%define tde_includedir %{tde_prefix}/include
-%define tde_libdir %{tde_prefix}/%{_lib}
-%define tde_mandir %{tde_datadir}/man
-%define tde_tdeappdir %{tde_datadir}/applications/tde
-%define tde_tdedocdir %{tde_docdir}/tde
-%define tde_tdeincludedir %{tde_includedir}/tde
-%define tde_tdelibdir %{tde_libdir}/trinity
-
-
-Name: trinity-%{tde_pkg}
-Epoch: %{tde_epoch}
-Version: 1.6.6.0
-Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
-Summary: A bible study tool for Trinity
-Group: Applications/Utilities
-URL: http://www.trinitydesktop.org/
-
-%if 0%{?suse_version}
-License: GPL-2.0+
-%else
-License: GPLv2+
-%endif
-
-#Vendor: Trinity Desktop
-#Packager: Francois Andriot <francois.andriot@free.fr>
-
-Prefix: %{_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-
-Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-
-BuildRequires: trinity-tdelibs-devel >= %{tde_version}
-BuildRequires: trinity-tdebase-devel >= %{tde_version}
-
-BuildRequires: autoconf automake libtool m4
-BuildRequires: gcc-c++
-BuildRequires: pkgconfig
-BuildRequires: libtool
-BuildRequires: desktop-file-utils
-BuildRequires: gettext
-
-# SUSE desktop files utility
-%if 0%{?suse_version}
-BuildRequires: update-desktop-files
-%endif
-
-%if 0%{?opensuse_bs} && 0%{?suse_version}
-# for xdg-menu script
-BuildRequires: brp-check-trinity
-%endif
-
-# BOOST support
-BuildRequires: boost-devel
-
-# Requires: clucene
-%if 0%{?fedora} || 0%{?suse_version} || 0%{?rhel} >= 6
-BuildRequires: clucene-core-devel
-%endif
-%if 0%{?mgaversion} || 0%{?mdkversion}
-BuildRequires: %{_lib}clucene-devel
-%endif
-
-# Requires: sword
-BuildRequires: sword-devel
-Requires: sword
-
-%description
-BibleTime is a free and easy to use bible study tool for UNIX systems.
-It requires a working TDE environment and the SWORD library.
-BibleTime provides easy handling of digitized texts (Bibles, commentaries
-and lexicons) and powerful features to work with these texts (search in
-texts, write own notes, save, print etc.).
-
-##########
-
-%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
-%debug_package
-%endif
-
-##########
-
-%prep
-%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-
-%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
-%__make -f "admin/Makefile.common"
-
-
-%build
-unset QTDIR QTINC QTLIB
-export PATH="%{tde_bindir}:${PATH}"
-export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig:${PKG_CONFIG_PATH}"
-
-%if 0%{?fedora} >= 31 || 0%{?rhel} >= 8
-CXXFLAGS="${RPM_OPT_FLAGS} -std=c++11"
-%endif
-
-%configure \
- --prefix=%{tde_prefix} \
- --exec-prefix=%{tde_prefix} \
- --bindir=%{tde_bindir} \
- --libdir=%{tde_libdir} \
- --datadir=%{tde_datadir} \
- --includedir=%{tde_tdeincludedir} \
- \
- --disable-dependency-tracking \
- --disable-debug \
- --enable-new-ldflags \
- --enable-final \
- --enable-closure \
- --enable-rpath \
- --disable-gcc-hidden-visibility
-
-# Not SMP safe !
-%__make -C bibletime/frontend
-
-# SMP safe !
-%__make %{?_smp_mflags} || %__make
-
-
-%install
-export PATH="%{tde_bindir}:${PATH}"
-%__rm -rf %{buildroot}
-%__make install DESTDIR=%{buildroot}
-
-%__chmod 644 %{buildroot}%{tde_datadir}/apps/bibletime/pics/*
-%__chmod 644 %{buildroot}%{tde_datadir}/apps/bibletime/bibletimeui.rc
-%__chmod 644 %{buildroot}%{tde_datadir}/apps/bibletime/tips
-
-echo "OnlyShowIn=TDE;" >>"%{?buildroot}%{tde_datadir}/applications/bibletime.desktop"
-
-
-%clean
-%__rm -rf %{buildroot}
-
-
-%files
-%defattr(-,root,root,-)
-%{tde_bindir}/bibletime
-%{tde_tdeincludedir}/bibletimeinterface.h
-%{tde_datadir}/applications/bibletime.desktop
-%{tde_datadir}/apps/bibletime/
-%{tde_datadir}/icons/hicolor/*/*/*.png
-%{tde_tdedocdir}/HTML/en/bibletime/
-
-
-%changelog