summaryrefslogtreecommitdiffstats
path: root/redhat/applications/k9copy/k9copy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/k9copy/k9copy.spec')
-rw-r--r--redhat/applications/k9copy/k9copy.spec190
1 files changed, 190 insertions, 0 deletions
diff --git a/redhat/applications/k9copy/k9copy.spec b/redhat/applications/k9copy/k9copy.spec
new file mode 100644
index 000000000..418bd3f47
--- /dev/null
+++ b/redhat/applications/k9copy/k9copy.spec
@@ -0,0 +1,190 @@
+#
+# spec file for package k9copy (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
+%define tde_version 14.0.7
+%endif
+%define tde_pkg k9copy
+%define tde_prefix /opt/trinity
+%define tde_appdir %{tde_datadir}/applications
+%define tde_bindir %{tde_prefix}/bin
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+%define tde_tdeappdir %{tde_datadir}/applications/tde
+%define tde_tdedocdir %{tde_docdir}/tde
+%define tde_tdeincludedir %{tde_includedir}/tde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 1.2.3
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: DVD backup tool for Trinity
+Group: Applications/Utilities
+URL: http://www.trinitydesktop.org/
+
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
+
+BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+BuildRequires: trinity-tdebase-devel >= %{tde_version}
+
+BuildRequires: desktop-file-utils
+BuildRequires: trinity-k3b-devel
+
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+# Warning: the target distribution must have ffmpeg !
+BuildRequires: ffmpeg-devel
+Requires: ffmpeg
+
+# DVDREAD support
+%if 0%{?mdkversion} || 0%{?mgaversion}
+BuildRequires: %{_lib}dvdread-devel
+%else
+BuildRequires: libdvdread-devel
+%endif
+
+# MESA support
+%if 0%{?rhel} || 0%{?fedora}
+BuildRequires: mesa-libGL-devel
+BuildRequires: mesa-libGLU-devel
+%endif
+%if 0%{?mdkversion} || 0%{?mgaversion}
+BuildRequires: mesaglu-devel
+%endif
+%if 0%{?suse_version}
+BuildRequires: Mesa-libGL-devel
+BuildRequires: Mesa-libGLU-devel
+%endif
+%if 0%{?rhel} == 4
+BuildRequires: xorg-x11-Mesa-libGLU
+%endif
+
+
+%description
+k9copy is a tabbed tool that allows to copy of one or more titles from a DVD9
+to a DVD5, in thesame way than DVDShrink for Microsoft Windows (R).
+This is the Trinity version.
+
+
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
+%debug_package
+%endif
+
+##########
+
+
+%prep
+%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
+
+# Removes internal dvdread headers
+%__rm -rf "dvdread"
+
+# Fix permissions on doc files
+chmod -x AUTHORS COPYING
+
+%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
+%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__make -f "admin/Makefile.common"
+
+
+%build
+unset QTDIR QTINC QTLIB
+export PATH="%{tde_bindir}:${PATH}"
+
+# FFMPEG ...
+if [ -d /usr/include/ffmpeg ]; then
+ export CXXFLAGS="${RPM_OPT_FLAGS} -I/usr/include/ffmpeg"
+fi
+
+# NOTICE: --enable-final causes FTBFS !
+%configure \
+ --prefix=%{tde_prefix} \
+ --exec-prefix=%{tde_prefix} \
+ --bindir=%{tde_bindir} \
+ --datadir=%{tde_datadir} \
+ --includedir=%{tde_tdeincludedir} \
+ \
+ --disable-dependency-tracking \
+ --disable-debug \
+ --disable-final \
+ --enable-new-ldflags \
+ --enable-closure \
+ --enable-rpath \
+ --disable-gcc-hidden-visibility \
+ \
+ --enable-k3bdevices
+
+%__make %{?_smp_mflags} || %__make
+
+
+%install
+export PATH="%{tde_bindir}:${PATH}"
+%__rm -rf %{buildroot}
+%__make install DESTDIR=%{buildroot}
+
+%find_lang %{tde_pkg}
+
+
+%clean
+%__rm -rf %{buildroot}
+
+
+%files -f %{tde_pkg}.lang
+%defattr(-,root,root,-)
+%doc AUTHORS COPYING
+%{tde_bindir}/k9copy
+%{tde_tdeappdir}/k9copy.desktop
+%{tde_datadir}/apps/k9copy/
+%{tde_datadir}/apps/konqueror/servicemenus/k9copy_open.desktop
+%lang(en) %{tde_tdedocdir}/HTML/en/k9copy/
+%{tde_datadir}/icons/hicolor/*/apps/k9copy.png
+
+
+%changelog