summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kbarcode/kbarcode-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kbarcode/kbarcode-14.0.0.spec')
-rw-r--r--redhat/applications/kbarcode/kbarcode-14.0.0.spec109
1 files changed, 68 insertions, 41 deletions
diff --git a/redhat/applications/kbarcode/kbarcode-14.0.0.spec b/redhat/applications/kbarcode/kbarcode-14.0.0.spec
index 5f122bd1a..6938322cb 100644
--- a/redhat/applications/kbarcode/kbarcode-14.0.0.spec
+++ b/redhat/applications/kbarcode/kbarcode-14.0.0.spec
@@ -1,57 +1,87 @@
-# Default version for this component
-%define tde_pkg kbarcode
+#
+# spec file for package kbarcode (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
%endif
-
-# TDE specific building variables
+%define tde_pkg kbarcode
+%define tde_prefix /opt/trinity
+%define tde_appdir %{tde_datadir}/applications
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-
-##########
Name: trinity-%{tde_pkg}
-Summary: barcode and label printing application for Trinity
+Epoch: %{tde_epoch}
Version: 2.0.7
-Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
-
-License: GPLv2+
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: barcode and label printing application for Trinity
Group: Applications/Utilities
-
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
URL: http://www.kbarcode.net
-Prefix: %{tde_prefix}
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{_prefix}
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
BuildRequires: gettext
-Requires: %{name}-tdefile-plugin = %{version}-%{release}
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+# PCRE support
+BuildRequires: pcre-devel
+
+Requires: %{name}-tdefile-plugin = %{?epoch:%{epoch}:}%{version}-%{release}
%description
@@ -73,16 +103,6 @@ supported. Even complex 2D barcodes are supported using third party tools. The
generated barcodes can be directly printed or you can export them into images
to use them in another application.
-%post
-touch --no-create %{tde_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
-update-desktop-database %{tde_appdir} &> /dev/null
-
-%postun
-touch --no-create %{tde_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
-update-desktop-database %{tde_appdir} &> /dev/null
-
%files -f %{tde_pkg}.lang
%defattr(-,root,root,-)
%doc AUTHORS ChangeLog COPYING NEWS README TODO
@@ -106,7 +126,7 @@ update-desktop-database %{tde_appdir} &> /dev/null
%package tdefile-plugin
Summary: tdefile-plugin for %{name}
Group: Applications/Utilities
-#Requires: %{name} = %{version}-%{release}
+#Requires: %{name} = %{?epoch:%{epoch}:}%{version}-%{release}
%description tdefile-plugin
%{summary}.
@@ -119,7 +139,7 @@ Group: Applications/Utilities
##########
-%if 0%{?suse_version} || 0%{?pclinuxos}
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
@@ -129,7 +149,7 @@ Group: Applications/Utilities
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
%__cp "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__cp "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
%__make -f "admin/Makefile.common"
@@ -164,9 +184,18 @@ export PATH="%{tde_bindir}:${PATH}"
%__rm -rf %{buildroot}
%__make install DESTDIR=%{buildroot}
-
%find_lang %{tde_pkg}
+# Fix invalid icon path
+%__sed -i "%{buildroot}%{tde_tdeappdir}/kbarcode.desktop" -e "s|Icon=.*|Icon=kbarcode|"
+
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+%suse_update_desktop_file -r kbarcode Utility PrintingUtility
+%suse_update_desktop_file -r kbarcode-batch Utility PrintingUtility
+%suse_update_desktop_file -r kbarcode-editor Utility PrintingUtility
+%suse_update_desktop_file -r kbarcode-single Utility PrintingUtility
+%endif
%clean
@@ -174,5 +203,3 @@ export PATH="%{tde_bindir}:${PATH}"
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 2.0.6-5
-- Initial release for TDE 14.0.0