summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kdbg/kdbg.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kdbg/kdbg.spec')
-rw-r--r--redhat/applications/kdbg/kdbg.spec172
1 files changed, 0 insertions, 172 deletions
diff --git a/redhat/applications/kdbg/kdbg.spec b/redhat/applications/kdbg/kdbg.spec
deleted file mode 100644
index 33fe3e918..000000000
--- a/redhat/applications/kdbg/kdbg.spec
+++ /dev/null
@@ -1,172 +0,0 @@
-#
-# spec file for package kdbg (version R14)
-#
-# Copyright (c) 2014 Trinity Desktop Environment
-#
-# All modifications and additions to the file contributed by third parties
-# remain the property of their copyright owners, unless otherwise agreed
-# upon. The license for this file, and modifications and additions to the
-# file, is the same license as for the pristine package itself (unless the
-# license for the pristine package is not an Open Source License, in which
-# case the license is the MIT License). An "Open Source License" is a
-# license that conforms to the Open Source Definition (Version 1.9)
-# published by the Open Source Initiative.
-#
-# Please submit bugfixes or comments via http://www.trinitydesktop.org/
-#
-
-# TDE variables
-%define tde_epoch 2
-%if "%{?tde_version}" == ""
-%define tde_version 14.0.9
-%endif
-%define tde_pkg kdbg
-%define tde_prefix /opt/trinity
-%define tde_bindir %{tde_prefix}/bin
-%define tde_confdir %{_sysconfdir}/trinity
-%define tde_datadir %{tde_prefix}/share
-%define tde_docdir %{tde_datadir}/doc
-%define tde_includedir %{tde_prefix}/include
-%define tde_libdir %{tde_prefix}/%{_lib}
-%define tde_mandir %{tde_datadir}/man
-%define tde_tdeappdir %{tde_datadir}/applications/tde
-%define tde_tdedocdir %{tde_docdir}/tde
-%define tde_tdeincludedir %{tde_includedir}/tde
-%define tde_tdelibdir %{tde_libdir}/trinity
-
-
-Name: trinity-%{tde_pkg}
-Epoch: %{tde_epoch}
-Version: 2.2.2
-Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
-Summary: Graphical debugger interface [Trinity]
-Group: Applications/Utilities
-URL: http://www.trinitydesktop.org/
-
-%if 0%{?suse_version}
-License: GPL-2.0+
-%else
-License: GPLv2+
-%endif
-
-#Vendor: Trinity Desktop
-#Packager: Francois Andriot <francois.andriot@free.fr>
-
-Prefix: %{_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-
-Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-
-BuildRequires: trinity-tdelibs-devel >= %{tde_version}
-BuildRequires: trinity-tdebase-devel >= %{tde_version}
-BuildRequires: desktop-file-utils
-
-BuildRequires: gettext
-
-BuildRequires: autoconf automake libtool m4
-BuildRequires: gcc-c++
-BuildRequires: pkgconfig
-
-# SUSE desktop files utility
-%if 0%{?suse_version}
-BuildRequires: update-desktop-files
-%endif
-
-%if 0%{?opensuse_bs} && 0%{?suse_version}
-# for xdg-menu script
-BuildRequires: brp-check-trinity
-%endif
-
-
-%description
-KDbg is a graphical user interface to gdb, the GNU debugger. It provides
-an intuitive interface for setting breakpoints, inspecting variables,
-stepping through code and much more. KDbg requires TDE but you can of
-course debug any program.
-
-KDbg can also debug XSLT (XML stylesheet translation) scripts by
-interfacing with xsldbg. For this the package kxsldbg must be installed.
-
-Features include the following:
-* Inspection of variable values in a tree structure.
-* Direct member: For certain compound data types the most important
- member values are displayed next to the variable name, so that it is
- not necessary to expand the subtree of that variable in order to see
- the member value. KDbg can also display Qt's QString values, which
- are Unicode strings.
-* Debugger at your finger tips: The basic debugger functions (step,
- next, run, finish, until, set/clear/enable/disable breakpoint) are
- bound to function keys F5 through F10. Quick and easy.
-* View source code, search text, set program arguments and environment
- variables, display arbitrary expressions.
-* Debugging of core dumps, attaching to running processes is possible.
-* Conditional breakpoints.
-
-##########
-
-%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
-%debug_package
-%endif
-
-##########
-
-%prep
-%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-
-%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
-%__make -f "admin/Makefile.common"
-
-
-%build
-unset QTDIR QTINC QTLIB
-export PATH="%{tde_bindir}:${PATH}"
-export kde_confdir="%{tde_confdir}"
-
-# Warning: --enable-final causes FTBFS
-%configure \
- --prefix=%{tde_prefix} \
- --exec-prefix=%{tde_prefix} \
- --bindir=%{tde_bindir} \
- --datadir=%{tde_datadir} \
- --includedir=%{tde_tdeincludedir} \
- --docdir=%{tde_tdedocdir} \
- --libdir=%{tde_libdir} \
- \
- --disable-dependency-tracking \
- --disable-debug \
- --enable-new-ldflags \
- --disable-final \
- --enable-closure \
- --enable-rpath \
- --disable-gcc-hidden-visibility
-
-%__make %{?_smp_mflags} || %__make
-
-
-%install
-export PATH="%{tde_bindir}:${PATH}"
-%__rm -rf %{buildroot}
-%__make install DESTDIR=%{buildroot}
-
-%find_lang %{tde_pkg}
-
-
-%clean
-%__rm -rf %{buildroot}
-
-
-%files -f %{tde_pkg}.lang
-%defattr(-,root,root,-)
-%{tde_bindir}/kdbg
-%{tde_tdeappdir}/kdbg.desktop
-%{tde_datadir}/apps/kdbg/
-%config(noreplace) %{tde_confdir}/kdbgrc
-%lang(de) %{tde_tdedocdir}/HTML/de/kdbg/
-%lang(en) %{tde_tdedocdir}/HTML/en/kdbg/
-%lang(ru) %{tde_tdedocdir}/HTML/ru/kdbg/
-%{tde_datadir}/icons/hicolor/*/apps/kdbg.png
-%{tde_datadir}/icons/locolor/*/apps/kdbg.png
-
-
-%changelog