summaryrefslogtreecommitdiffstats
path: root/redhat/applications/keep/keep.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/keep/keep.spec')
-rw-r--r--redhat/applications/keep/keep.spec170
1 files changed, 170 insertions, 0 deletions
diff --git a/redhat/applications/keep/keep.spec b/redhat/applications/keep/keep.spec
new file mode 100644
index 000000000..2afb9b1ca
--- /dev/null
+++ b/redhat/applications/keep/keep.spec
@@ -0,0 +1,170 @@
+#
+# spec file for package keep (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
+%define tde_version 14.0.7
+%endif
+%define tde_pkg keep
+%define tde_prefix /opt/trinity
+%define tde_bindir %{tde_prefix}/bin
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+%define tde_tdeappdir %{tde_datadir}/applications/tde
+%define tde_tdedocdir %{tde_docdir}/tde
+%define tde_tdeincludedir %{tde_includedir}/tde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 0.4.0
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: Backup system for TDE [Trinity]
+Group: Applications/Utilities
+URL: http://www.trinitydesktop.org/
+
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
+
+BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+BuildRequires: trinity-tdebase-devel >= %{tde_version}
+BuildRequires: desktop-file-utils
+
+BuildRequires: gettext
+
+BuildRequires: cmake >= 2.8
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: libtool
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+Requires: rdiff-backup
+
+
+%description
+Keep is an automatic backup program that allows users to set the parameters of
+the backup, including the frequency and the number of backups.
+
+Homepage: http://jr.falleri.free.fr/keep
+
+
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
+%debug_package
+%endif
+
+##########
+
+
+%prep
+%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
+
+
+%build
+unset QTDIR QTINC QTLIB
+export PATH="%{tde_bindir}:${PATH}"
+export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
+
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
+
+%cmake \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
+ -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_SKIP_RPATH=OFF \
+ -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DWITH_GCC_VISIBILITY=OFF \
+ \
+ -DCMAKE_INSTALL_PREFIX="%{tde_prefix}" \
+ -DSHARE_INSTALL_PREFIX="%{tde_datadir}" \
+ -DLIB_INSTALL_DIR="%{tde_libdir}" \
+ -DPLUGIN_INSTALL_DIR="%{tde_tdelibdir}" \
+ \
+ -DWITH_ALL_OPTIONS=ON \
+ -DWITH_GCC_VISIBILITY=ON \
+ \
+ -DBUILD_ALL=ON \
+ -DBUILD_DOC=ON \
+ -DBUILD_TRANSLATIONS=ON \
+ \
+ ..
+
+%__make %{?_smp_mflags} || %__make
+
+
+%install
+export PATH="%{tde_bindir}:${PATH}"
+%__rm -rf %{buildroot}
+%__make install DESTDIR=%{buildroot} -C build
+
+%find_lang %{tde_pkg}
+
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+%suse_update_desktop_file -r "%{?buildroot}%{tde_tdeappdir}/keep.desktop" System Backup
+%endif
+
+
+%clean
+%__rm -rf %{buildroot}
+
+
+%files -f %{tde_pkg}.lang
+%defattr(-,root,root,-)
+%{tde_bindir}/keep
+%{tde_tdelibdir}/kded_keep.la
+%{tde_tdelibdir}/kded_keep.so
+%{tde_tdeappdir}/keep.desktop
+%{tde_datadir}/icons/hicolor/scalable/apps/keep.svgz
+%{tde_datadir}/apps/keep/
+%{tde_datadir}/config.kcfg/keepsettings.kcfg
+%{tde_datadir}/icons/hicolor/*/apps/keep.png
+%{tde_datadir}/services/kded/keep.desktop
+%{tde_mandir}/man1/keep.*
+
+
+%changelog