summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kgtk-qt3/kgtk-qt3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kgtk-qt3/kgtk-qt3.spec')
-rw-r--r--redhat/applications/kgtk-qt3/kgtk-qt3.spec187
1 files changed, 187 insertions, 0 deletions
diff --git a/redhat/applications/kgtk-qt3/kgtk-qt3.spec b/redhat/applications/kgtk-qt3/kgtk-qt3.spec
new file mode 100644
index 000000000..0f5e282f7
--- /dev/null
+++ b/redhat/applications/kgtk-qt3/kgtk-qt3.spec
@@ -0,0 +1,187 @@
+#
+# spec file for package kgtk-qt3 (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
+%define tde_version 14.1.0
+%endif
+%define tde_pkg kgtk-qt3
+%define tde_prefix /opt/trinity
+%define tde_bindir %{tde_prefix}/bin
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+%define tde_tdeappdir %{tde_datadir}/applications/tde
+%define tde_tdedocdir %{tde_docdir}/tde
+%define tde_tdeincludedir %{tde_includedir}/tde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 0.10.2
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: Use TDE dialogs in Gtk apps
+Group: Applications/Utilities
+URL: http://www.trinitydesktop.org
+
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
+
+BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+BuildRequires: trinity-tdebase-devel >= %{tde_version}
+BuildRequires: desktop-file-utils
+
+BuildRequires: gettext
+
+BuildRequires: cmake libtool
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+# IDN support
+BuildRequires: libidn-devel
+
+# GTK2 support
+%if 0%{?fedora} || 0%{?suse_version} || 0%{?rhel}
+BuildRequires: gtk2-devel
+%else
+BuildRequires: gtk+2.0-devel
+%endif
+
+# GAMIN support
+# Not on openSUSE.
+%if 0%{?rhel} || 0%{?fedora} || 0%{?mgaversion} || 0%{?mdkversion}
+%define with_gamin 1
+BuildRequires: gamin-devel
+%endif
+
+# ACL support
+BuildRequires: libacl-devel
+
+# OPENSSL support
+BuildRequires: openssl-devel
+
+
+%description
+This is an LD_PRELOAD hack that allows most GTK
+applications to use Trinity's file dialogs when run under Trinity.
+
+The Gtk file chooser functions have been overridden to communicate
+with this TDE module/application.
+
+This package includes the kqt3-wrapper
+
+
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
+%debug_package
+%endif
+
+##########
+
+
+%prep
+%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
+
+%build
+unset QTDIR QTINC QTLIB
+export PATH="%{tde_bindir}:${PATH}"
+export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig:${PKG_CONFIG_PATH}"
+
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
+
+
+%cmake \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
+ -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_SKIP_RPATH=OFF \
+ -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DWITH_GCC_VISIBILITY=OFF \
+ \
+ -DCMAKE_INSTALL_PREFIX=%{tde_prefix} \
+ -DBIN_INSTALL_DIR=%{tde_bindir} \
+ -DINCLUDE_INSTALL_DIR=%{tde_tdeincludedir} \
+ -DLIB_INSTALL_DIR=%{tde_libdir} \
+ -DSHARE_INSTALL_PREFIX=%{tde_datadir} \
+ \
+ -DBUILD_ALL=ON \
+ ..
+
+# SMP safe !
+%__make %{?_smp_mflags}
+
+
+%install
+export PATH="%{tde_bindir}:${PATH}"
+%__rm -rf %{buildroot}
+%__make install DESTDIR=%{buildroot} -C build
+
+# The "preload" file is used by "startkde" script
+%__install -d -m 755 "%{buildroot}%{tde_datadir}/kgtk"
+echo "%{tde_libdir}/kgtk/libkgtk2.so" >"%{buildroot}%{tde_datadir}/kgtk/preload"
+
+%find_lang kgtk
+
+
+
+%clean
+%__rm -rf %{buildroot}
+
+
+%files -f kgtk.lang
+%defattr(-,root,root,-)
+%doc AUTHORS ChangeLog COPYING README TODO
+%{tde_bindir}/kdialogd-wrapper
+%{tde_bindir}/kdialogd3
+%{tde_bindir}/kgtk-wrapper
+%{tde_bindir}/kgtk2-wrapper
+%{tde_bindir}/kqt3-wrapper
+%{tde_libdir}/kgtk/libkgtk2.so
+%{tde_libdir}/kgtk/libkqt3.so
+%{tde_datadir}/kgtk/preload
+
+%changelog