summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kpicosim/kpicosim.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kpicosim/kpicosim.spec')
-rw-r--r--redhat/applications/kpicosim/kpicosim.spec172
1 files changed, 0 insertions, 172 deletions
diff --git a/redhat/applications/kpicosim/kpicosim.spec b/redhat/applications/kpicosim/kpicosim.spec
deleted file mode 100644
index 0b175326b..000000000
--- a/redhat/applications/kpicosim/kpicosim.spec
+++ /dev/null
@@ -1,172 +0,0 @@
-#
-# spec file for package kpicosim (version R14)
-#
-# Copyright (c) 2014 Trinity Desktop Environment
-#
-# All modifications and additions to the file contributed by third parties
-# remain the property of their copyright owners, unless otherwise agreed
-# upon. The license for this file, and modifications and additions to the
-# file, is the same license as for the pristine package itself (unless the
-# license for the pristine package is not an Open Source License, in which
-# case the license is the MIT License). An "Open Source License" is a
-# license that conforms to the Open Source Definition (Version 1.9)
-# published by the Open Source Initiative.
-#
-# Please submit bugfixes or comments via http://www.trinitydesktop.org/
-#
-
-# TDE variables
-%define tde_epoch 2
-%if "%{?tde_version}" == ""
-%define tde_version 14.1.0
-%endif
-%define tde_pkg kpicosim
-%define tde_prefix /opt/trinity
-%define tde_bindir %{tde_prefix}/bin
-%define tde_datadir %{tde_prefix}/share
-%define tde_docdir %{tde_datadir}/doc
-%define tde_includedir %{tde_prefix}/include
-%define tde_libdir %{tde_prefix}/%{_lib}
-%define tde_mandir %{tde_datadir}/man
-%define tde_tdeappdir %{tde_datadir}/applications/tde
-%define tde_tdedocdir %{tde_docdir}/tde
-%define tde_tdeincludedir %{tde_includedir}/tde
-%define tde_tdelibdir %{tde_libdir}/trinity
-
-
-Name: trinity-%{tde_pkg}
-Epoch: %{tde_epoch}
-Version: 0.6a
-Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
-Summary: IDE and simulator for the Xilinx PicoBlaze-3 [Trinity]
-Group: Applications/Utilities
-URL: http://www.trinitydesktop.org
-
-%if 0%{?suse_version}
-License: GPL-2.0+
-%else
-License: GPLv2+
-%endif
-
-#Vendor: Trinity Desktop
-#Packager: Francois Andriot <francois.andriot@free.fr>
-
-Prefix: %{tde_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-
-Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-
-BuildRequires: trinity-tdelibs-devel >= %{tde_version}
-BuildRequires: trinity-tdebase-devel >= %{tde_version}
-BuildRequires: desktop-file-utils
-BuildRequires: gettext
-
-BuildRequires: cmake
-BuildRequires: gcc-c++
-BuildRequires: pkgconfig
-BuildRequires: fdupes
-
-# IDN support
-BuildRequires: libidn-devel
-
-# ACL support
-BuildRequires: libacl-devel
-
-# OPENSSL support
-BuildRequires: openssl-devel
-
-# SUSE desktop files utility
-%if 0%{?suse_version}
-BuildRequires: update-desktop-files
-%endif
-
-%if 0%{?opensuse_bs} && 0%{?suse_version}
-# for xdg-menu script
-BuildRequires: brp-check-trinity
-%endif
-
-
-%description
-kpicosim is a development environment for the Xilinx
-PicoBlaze-3 soft-core processor for the TDE Desktop (Linux).
-The environment has an editor with syntax highlighting, compiler,
-simulator and export functions to VHDL, HEX and MEM files.
-
-
-##########
-
-%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
-%debug_package
-%endif
-
-##########
-
-
-%prep
-%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-
-
-%build
-unset QTDIR QTINC QTLIB
-export PATH="%{tde_bindir}:${PATH}"
-
-if ! rpm -E %%cmake|grep -q "cd build"; then
- %__mkdir_p build
- cd build
-fi
-
-%cmake \
- -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
- -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS}" \
- -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS}" \
- -DCMAKE_SKIP_RPATH=OFF \
- -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
- -DCMAKE_VERBOSE_MAKEFILE=ON \
- -DWITH_GCC_VISIBILITY=OFF \
- \
- -DCMAKE_INSTALL_PREFIX=%{tde_prefix} \
- -DSHARE_INSTALL_PREFIX=%{tde_datadir} \
- -DBUILD_ALL=ON \
- ..
-
-%__make %{?_smp_mflags}
-
-
-%install
-export PATH="%{tde_bindir}:${PATH}"
-%__rm -rf %{buildroot}
-%__make install DESTDIR=%{buildroot} -C build
-
-%find_lang %{tde_pkg}
-
-# Move desktop icon to XDG directory
-if [ -d "%{buildroot}%{tde_datadir}/applnk" ]; then
- %__mkdir_p %{buildroot}%{tde_tdeappdir}
- %__mv "%{buildroot}%{tde_datadir}/applnk/Development/kpicosim.desktop" "%{buildroot}%{tde_tdeappdir}/%{tde_pkg}.desktop"
- %__rm -r "%{buildroot}%{tde_datadir}/applnk"
-fi
-
-
-# Updates applications categories for openSUSE
-%if 0%{?suse_version}
-%suse_update_desktop_file -D kpicosim -C "%summary" kpicosim Development IDE
-%endif
-
-
-%clean
-%__rm -rf %{buildroot}
-
-
-%files -f %{tde_pkg}.lang
-%defattr(-,root,root,-)
-%doc AUTHORS ChangeLog COPYING README
-%{tde_bindir}/kpicosim
-%{tde_tdeappdir}/kpicosim.desktop
-%{tde_datadir}/apps/katepart/syntax/psm.xml
-%{tde_datadir}/apps/kpicosim
-%{tde_tdedocdir}/HTML/en/kpicosim
-%{tde_datadir}/icons/hicolor/*/apps/kpicosim.png
-%{tde_mandir}/man*/kpicosim.*
-
-
-%changelog