summaryrefslogtreecommitdiffstats
path: root/redhat/applications/tdeio-locate/tdeio-locate.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/tdeio-locate/tdeio-locate.spec')
-rw-r--r--redhat/applications/tdeio-locate/tdeio-locate.spec176
1 files changed, 0 insertions, 176 deletions
diff --git a/redhat/applications/tdeio-locate/tdeio-locate.spec b/redhat/applications/tdeio-locate/tdeio-locate.spec
deleted file mode 100644
index 7b95bc677..000000000
--- a/redhat/applications/tdeio-locate/tdeio-locate.spec
+++ /dev/null
@@ -1,176 +0,0 @@
-#
-# spec file for package tdeio-locate (version R14)
-#
-# Copyright (c) 2014 Trinity Desktop Environment
-#
-# All modifications and additions to the file contributed by third parties
-# remain the property of their copyright owners, unless otherwise agreed
-# upon. The license for this file, and modifications and additions to the
-# file, is the same license as for the pristine package itself (unless the
-# license for the pristine package is not an Open Source License, in which
-# case the license is the MIT License). An "Open Source License" is a
-# license that conforms to the Open Source Definition (Version 1.9)
-# published by the Open Source Initiative.
-#
-# Please submit bugfixes or comments via http://www.trinitydesktop.org/
-#
-
-# TDE variables
-%define tde_epoch 2
-%if "%{?tde_version}" == ""
-%define tde_version 14.0.9
-%endif
-%define tde_pkg tdeio-locate
-%define tde_prefix /opt/trinity
-%define tde_bindir %{tde_prefix}/bin
-%define tde_datadir %{tde_prefix}/share
-%define tde_docdir %{tde_datadir}/doc
-%define tde_includedir %{tde_prefix}/include
-%define tde_libdir %{tde_prefix}/%{_lib}
-%define tde_mandir %{tde_datadir}/man
-%define tde_tdeappdir %{tde_datadir}/applications/tde
-%define tde_tdedocdir %{tde_docdir}/tde
-%define tde_tdeincludedir %{tde_includedir}/tde
-%define tde_tdelibdir %{tde_libdir}/trinity
-
-
-Name: trinity-%{tde_pkg}
-Epoch: %{tde_epoch}
-Version: 0.4.5
-Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
-Summary: Tdeio-slave for the locate command [Trinity]
-Group: Applications/Utilities
-URL: http://www.trinitydesktop.org
-
-%if 0%{?suse_version}
-License: GPL-2.0+
-%else
-License: GPLv2+
-%endif
-
-#Vendor: Trinity Desktop
-#Packager: Francois Andriot <francois.andriot@free.fr>
-
-Prefix: %{tde_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-
-Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-
-BuildRequires: trinity-tdelibs-devel >= %{tde_version}
-BuildRequires: trinity-tdebase-devel >= %{tde_version}
-BuildRequires: desktop-file-utils
-
-BuildRequires: cmake >= 2.8
-BuildRequires: libtool
-BuildRequires: gcc-c++
-BuildRequires: pkgconfig
-BuildRequires: fdupes
-
-# SUSE desktop files utility
-%if 0%{?suse_version}
-BuildRequires: update-desktop-files
-%endif
-
-%if 0%{?opensuse_bs} && 0%{?suse_version}
-# for xdg-menu script
-BuildRequires: brp-check-trinity
-%endif
-
-# ACL support
-BuildRequires: libacl-devel
-
-# IDN support
-BuildRequires: libidn-devel
-
-# GAMIN support
-# Not on openSUSE.
-%if 0%{?rhel} || 0%{?fedora} || 0%{?mgaversion} || 0%{?mdkversion}
-%define with_gamin 1
-BuildRequires: gamin-devel
-%endif
-
-# OPENSSL support
-BuildRequires: openssl-devel
-
-Obsoletes: trinity-kio-locate < %{version}-%{release}
-Provides: trinity-kio-locate = %{version}-%{release}
-
-
-%description
-Adds support for the "locate" and "locater:"
-protocols to Konqueror and other TDE applications.
-
-This enables you to perform locate searches as you
-would in a terminal. The result is displayed just
-as a directory.
-
-
-##########
-
-%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
-%debug_package
-%endif
-
-##########
-
-
-%prep
-%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-
-
-%build
-unset QTDIR QTINC QTLIB
-export PATH="%{tde_bindir}:${PATH}"
-export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig:${PKG_CONFIG_PATH}"
-
-if ! rpm -E %%cmake|grep -q "cd build"; then
- %__mkdir_p build
- cd build
-fi
-
-%cmake \
- -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
- -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS}" \
- -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS}" \
- -DCMAKE_SKIP_RPATH=OFF \
- -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
- -DCMAKE_VERBOSE_MAKEFILE=ON \
- -DWITH_GCC_VISIBILITY=OFF \
- \
- -DCMAKE_INSTALL_PREFIX=%{tde_prefix} \
- -DBIN_INSTALL_DIR=%{tde_bindir} \
- -DINCLUDE_INSTALL_DIR=%{tde_tdeincludedir} \
- -DLIB_INSTALL_DIR=%{tde_libdir} \
- -DSHARE_INSTALL_PREFIX=%{tde_datadir} \
- \
- -DBUILD_ALL=ON \
- ..
-
-# SMP safe !
-%__make %{?_smp_mflags}
-
-
-%install
-export PATH="%{tde_bindir}:${PATH}"
-%__rm -rf %{buildroot}
-%__make install DESTDIR=%{buildroot} -C build
-
-%find_lang %{tde_pkg}
-
-%clean
-%__rm -rf %{buildroot}
-
-
-
-%files -f %{tde_pkg}.lang
-%defattr(-,root,root,-)
-%doc AUTHORS ChangeLog COPYING TODO
-%{tde_tdelibdir}/tdeio_locate.la
-%{tde_tdelibdir}/tdeio_locate.so
-%{tde_tdedocdir}/HTML/en/tdeio-locate/
-%{tde_datadir}/services/locate.protocol
-%{tde_datadir}/services/locater.protocol
-%{tde_datadir}/services/rlocate.protocol
-%{tde_datadir}/services/searchproviders/locate.desktop
-
-%changelog