summaryrefslogtreecommitdiffstats
path: root/redhat/applications/twin-style-crystal/twin-style-crystal.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/twin-style-crystal/twin-style-crystal.spec')
-rw-r--r--redhat/applications/twin-style-crystal/twin-style-crystal.spec154
1 files changed, 154 insertions, 0 deletions
diff --git a/redhat/applications/twin-style-crystal/twin-style-crystal.spec b/redhat/applications/twin-style-crystal/twin-style-crystal.spec
new file mode 100644
index 000000000..2f5611335
--- /dev/null
+++ b/redhat/applications/twin-style-crystal/twin-style-crystal.spec
@@ -0,0 +1,154 @@
+#
+# spec file for package twin-style-crystal (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
+%define tde_version 14.1.0
+%endif
+%define tde_pkg twin-style-crystal
+%define tde_prefix /opt/trinity
+%define tde_bindir %{tde_prefix}/bin
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+%define tde_tdeappdir %{tde_datadir}/applications/tde
+%define tde_tdedocdir %{tde_docdir}/tde
+%define tde_tdeincludedir %{tde_includedir}/tde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 1.0.5
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: Semi transparant window decoration for Trinity
+Group: Applications/Utilities
+URL: http://www.trinitydesktop.org/
+
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
+
+BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+BuildRequires: trinity-tdebase-devel >= %{tde_version}
+BuildRequires: desktop-file-utils
+BuildRequires: gettext
+
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: fdupes
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+Obsoletes: trinity-kwin-style-crystal < %{version}-%{release}
+Provides: trinity-kwin-style-crystal = %{version}-%{release}
+
+
+%description
+Crystal offers you pseudo transparent titlebar, buttons and borders
+transparent, so you can see more of your lovely background image
+Transparancy and buttons can be costumized to match your wishes.
+Offers rounded corners as well
+
+And it is of course nice to look at. Upstream says:
+"- Don't forget to breathe, while drooling."
+
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
+%debug_package
+%endif
+
+##########
+
+%prep
+%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
+
+%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
+%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__make -f "admin/Makefile.common"
+
+
+%build
+unset QTDIR QTINC QTLIB
+export PATH="%{tde_bindir}:${PATH}"
+
+# Warning: --enable-gcc-visibility makes decoration unusable.
+%configure \
+ --prefix=%{tde_prefix} \
+ --exec-prefix=%{tde_prefix} \
+ --bindir=%{tde_bindir} \
+ --datadir=%{tde_datadir} \
+ --includedir=%{tde_tdeincludedir} \
+ --libdir=%{tde_libdir} \
+ --mandir=%{tde_mandir} \
+ \
+ --disable-dependency-tracking \
+ --disable-debug \
+ --enable-final \
+ --enable-new-ldflags \
+ --enable-closure \
+ --enable-rpath \
+ --disable-gcc-hidden-visibility
+
+%__make %{?_smp_mflags}
+
+
+%install
+export PATH="%{tde_bindir}:${PATH}"
+%__rm -rf %{buildroot}
+%__make install DESTDIR=%{buildroot}
+
+
+%clean
+%__rm -rf %{buildroot}
+
+
+
+%files
+%defattr(-,root,root,-)
+%doc AUTHORS COPYING
+%{tde_tdelibdir}/twin3_crystal.la
+%{tde_tdelibdir}/twin3_crystal.so
+%{tde_tdelibdir}/twin_crystal_config.la
+%{tde_tdelibdir}/twin_crystal_config.so
+%{tde_datadir}/apps/twin/crystal.desktop
+
+
+%changelog