summaryrefslogtreecommitdiffstats
path: root/redhat/applications/wlassistant/wlassistant-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/wlassistant/wlassistant-14.0.0.spec')
-rw-r--r--redhat/applications/wlassistant/wlassistant-14.0.0.spec131
1 files changed, 91 insertions, 40 deletions
diff --git a/redhat/applications/wlassistant/wlassistant-14.0.0.spec b/redhat/applications/wlassistant/wlassistant-14.0.0.spec
index 70298de9d..fdd4e9b31 100644
--- a/redhat/applications/wlassistant/wlassistant-14.0.0.spec
+++ b/redhat/applications/wlassistant/wlassistant-14.0.0.spec
@@ -1,56 +1,110 @@
-# Default version for this component
-%define tde_pkg wlassistant
+#
+# spec file for package wlassistant (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
%endif
-
-# TDE specific building variables
+%define tde_pkg wlassistant
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_tdedocdir}
-
-Name: trinity-%{tde_pkg}
-Summary: User friendly TDE frontend for wireless network connection [Trinity]
-Version: 0.5.7
-Release: %{?!preversion:5}%{?preversion:4_%{preversion}}%{?dist}%{?_variant}
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 0.5.7
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: User friendly TDE frontend for wireless network connection
+Group: Applications/Utilities
+URL: http://wlassistant.sourceforge.net/
-License: GPLv2+
-Group: Applications/Utilities
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-URL: http://wlassistant.sourceforge.net/
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
-Prefix: %{tde_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
-
BuildRequires: gettext
+BuildRequires: cmake libtool
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: fdupes
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+# Wireless support
+%if 0%{?fedora} >= 6 || 0%{?rhel} >= 5
+BuildRequires: wireless-tools-devel
+%endif
+%if 0%{?mgaversion} == 2 || 0%{?mdkversion}
+BuildRequires: %{_lib}iw29-devel
+%endif
+%if 0%{?rhel} == 5 || 0%{?suse_version}
+BuildRequires: wireless-tools
+%endif
+%if 0%{?suse_version} || 0%{?mgaversion} >= 3
+BuildRequires: libiw-devel
+%endif
+
+# IDN support
+BuildRequires: libidn-devel
+
+# GAMIN support
+# Not on openSUSE.
+%if 0%{?rhel} || 0%{?fedora} || 0%{?mgaversion} || 0%{?mdkversion}
+%define with_gamin 1
+BuildRequires: gamin-devel
+%endif
+# PYTHON support
BuildRequires: python
-BuildRequires: cmake >= 2.8
+
+# OPENSSL support
+BuildRequires: openssl-devel
+
%description
Wireless Assistant scans for wireless access points and displays link quality,
@@ -59,11 +113,13 @@ network, Wireless Assistant opens up its wizards and guides the user through
Wi-Fi settings. After a successful connection is made the settings are
remembered so next time the user won't have to enter them again.
+##########
-%if 0%{?suse_version} || 0%{?pclinuxos}
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
@@ -110,17 +166,14 @@ export PATH="%{tde_bindir}:${PATH}"
%__rm -rf %{buildroot}
%__make install DESTDIR=%{buildroot} -C build
-%clean
-%__rm -rf %{buildroot}
-
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+%suse_update_desktop_file -i -r "%{?buildroot}%{tde_tdeappdir}/wlassistant.desktop" System Network
+%endif
-%post
-touch --no-create %{tde_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
-%postun
-touch --no-create %{tde_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
+%clean
+%__rm -rf %{buildroot}
%files
@@ -143,5 +196,3 @@ gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 0.5.7-5
-- Initial release for TDE 14.0.0