summaryrefslogtreecommitdiffstats
path: root/redhat/dependencies/sip4-tqt/sip4-tqt-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/dependencies/sip4-tqt/sip4-tqt-14.0.0.spec')
-rw-r--r--redhat/dependencies/sip4-tqt/sip4-tqt-14.0.0.spec166
1 files changed, 166 insertions, 0 deletions
diff --git a/redhat/dependencies/sip4-tqt/sip4-tqt-14.0.0.spec b/redhat/dependencies/sip4-tqt/sip4-tqt-14.0.0.spec
new file mode 100644
index 000000000..dab4f51e0
--- /dev/null
+++ b/redhat/dependencies/sip4-tqt/sip4-tqt-14.0.0.spec
@@ -0,0 +1,166 @@
+#
+# spec file for package sip4-tqt (version R14.0.0)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http:/www.trinitydesktop.org/
+#
+
+# BUILD WARNING:
+# Remove qt-devel and qt3-devel and any kde*-devel on your system !
+# Having KDE libraries may cause FTBFS here !
+
+# Note for RHEL6 / Fedora:
+# Do *NOT* use 'byacc' to build sip4-tqt.
+# Instead, use 'bison' with a wrapper shell script.
+# e.g. /usr/local/bin/yacc
+# contains 'bison --yacc $@'
+
+# TDE variables
+%define tde_epoch 2
+%define tde_pkg sip4-tqt
+%define tde_version 14.0.0
+
+# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
+%if "%{?tde_prefix}" != "/usr"
+%define _variant .opt
+%endif
+
+%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+
+%define tde_bindir %{tde_prefix}/bin
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 4.10.5
+Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+Summary: Python/C++ bindings generator runtime library
+Group: System Environment/Libraries
+URL: http://www.trinitydesktop.org/
+
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
+
+BuildRequires: libtqt4-devel >= %{tde_epoch}:4.2.0
+
+BuildRequires: python
+
+%description
+SIP is a tool for generating bindings for C++ classes with some ideas
+borrowed from SWIG, but capable of tighter bindings because of its
+specificity towards C++ and Python.
+
+##########
+
+%package -n sip4-tqt
+Summary: Python/C++ bindings generator runtime library
+Group: System Environment/Libraries
+
+%description -n sip4-tqt
+SIP is a tool for generating bindings for C++ classes with some ideas
+borrowed from SWIG, but capable of tighter bindings because of its
+specificity towards C++ and Python.
+
+%files -n sip4-tqt
+%defattr(-,root,root,-)
+%dir %{python_sitearch}/sip4_tqt
+%{python_sitearch}/sip4_tqt/sip.so
+%{python_sitearch}/sip4_tqt/sipconfig.py*
+%{python_sitearch}/sip4_tqt/sipdistutils.py*
+%{python_sitearch}/sip4_tqt/__init__.py*
+
+##########
+
+%package -n sip4-tqt-devel
+Summary: Python/C++ bindings generator development files
+Group: Development/Libraries
+Requires: %{name} = %{version}-%{release}
+
+%description -n sip4-tqt-devel
+SIP is a tool for generating bindings for C++ classes with some ideas
+borrowed from SWIG, but capable of tighter bindings because of its
+specificity towards C++ and Python.
+
+SIP was originally designed to generate Python bindings for KDE and so
+has explicit support for the signal slot mechanism used by the Qt/KDE
+class libraries.
+
+Features:
+- connecting TQt signals to Python functions and class methods
+- connecting Python signals to TQt slots
+- overloading virtual member functions with Python class methods
+- protected member functions
+- abstract classes
+- enumerated types
+- global class instances
+- static member functions.
+
+This package contains the code generator tool and the development headers
+needed to develop Python bindings with sip.
+
+%files -n sip4-tqt-devel
+%defattr(-,root,root,-)
+%{tde_bindir}/sip
+%{tde_includedir}/sip.h
+
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
+%debug_package
+%endif
+
+##########
+
+%prep
+%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
+
+
+%build
+unset QTDIR QTINC QTLIB
+export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
+
+mkdir build
+cd build
+%__python ../configure.py \
+ -b %{tde_bindir} \
+ -d %{python_sitearch}/sip4_tqt \
+ -e %{tde_includedir} \
+ -u STRIP="" \
+ CFLAGS="${RPM_OPT_FLAGS} -I%{_includedir}/tqt -I%{_includedir}/tqt3 -I${PWD}/../sipgen -DYYERROR_VERBOSE" \
+ CXXFLAGS="${RPM_OPT_FLAGS} -I%{_includedir}/tqt -I%{_includedir}/tqt3 -I${PWD}/../sipgen -DYYERROR_VERBOSE"
+
+
+%install
+%__rm -rf %{?buildroot}
+%__make install DESTDIR=%{?buildroot} -C build
+
+
+%clean
+%__rm -rf %{?buildroot}
+
+
+%changelog
+* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 4.10.5-1
+- Initial release for TDE R14, using 'tqt3' instead of 'qt3'