summaryrefslogtreecommitdiffstats
path: root/redhat/dependencies/tqscintilla/tqscintilla-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/dependencies/tqscintilla/tqscintilla-14.0.0.spec')
-rw-r--r--redhat/dependencies/tqscintilla/tqscintilla-14.0.0.spec26
1 files changed, 15 insertions, 11 deletions
diff --git a/redhat/dependencies/tqscintilla/tqscintilla-14.0.0.spec b/redhat/dependencies/tqscintilla/tqscintilla-14.0.0.spec
index b8c7e0690..b9d293309 100644
--- a/redhat/dependencies/tqscintilla/tqscintilla-14.0.0.spec
+++ b/redhat/dependencies/tqscintilla/tqscintilla-14.0.0.spec
@@ -1,5 +1,5 @@
#
-# spec file for package tqscintilla (version R14.0.0)
+# spec file for package tqscintilla (version R14)
#
# Copyright (c) 2014 Trinity Desktop Environment
#
@@ -12,12 +12,14 @@
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
#
-# Please submit bugfixes or comments via http:/www.trinitydesktop.org/
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
#
# TDE variables
%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
+%endif
%define tde_pkg tqscintilla
%define tde_prefix /opt/trinity
%define tde_datadir %{tde_prefix}/share
@@ -33,7 +35,7 @@
Name: trinity-%{tde_pkg}
Epoch: %{tde_epoch}
Version: 1.7.1
-Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
Summary: TQt source code editing component based on Scintilla
Group: Development/Libraries/C and C++
URL: http://www.trinitydesktop.org/
@@ -172,6 +174,11 @@ export QTDIR=%{_libdir}/tqt3
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
+# Workaround strange tqmake behaviour in RHEL5
+%if 0%{?rhel} == 5
+%__sed -i "qt/Makefile" -e "s|..\/..\/..\/..\/..|%{_prefix}|g"
+%endif
+
%__make %{?_smp_mflags} -C qt
%__make %{?_smp_mflags} -C designer
@@ -186,29 +193,28 @@ export QTDIR=%{_libdir}/tqt3
# Installs supplementary headers
for i in include/*.h; do
- %__install -D -m 644 $i %{buildroot}${QTINC}/private/${i##*/}
+ %__install -D -m 644 $i %{buildroot}${QTINC}/private/${i##*/}
done
# Installs the HTML documentation correctly
for i in doc/html/*; do
- %__install -D -m 644 $i %{buildroot}%{tde_tdedocdir}/HTML/en/%{name}/${i##*/}
+ %__install -D -m 644 $i %{buildroot}%{tde_tdedocdir}/HTML/en/%{name}/${i##*/}
done
# Installs the Designer plugin
-for i in designer/*.so; do
- %__install -D -m 644 $i %{buildroot}${QTDIR}/plugins/designer/${i##*/}
+for i in designer/*.so ${QTDIR}/plugins/designer/*.so; do
+ [ -r "${i}" ] || continue
+ %__install -D -m 644 $i %{buildroot}${QTDIR}/plugins/designer/${i##*/}
done
# Installs libraries
%__mkdir_p %{buildroot}%{_libdir}
%__mv -f tmplib/* %{buildroot}%{_libdir}
-
# Fix private headers location
%__mv -f %{buildroot}/private %{buildroot}%{_includedir}/tqt3
%__mv -f %{buildroot}%{_includedir}/tqt3 %{buildroot}%{_includedir}/tqscintilla
-
# Fix permissions
chmod a-x %{buildroot}%{_includedir}/tqscintilla/*.h
chmod a-x %{buildroot}%{_includedir}/tqscintilla/*.h
@@ -219,5 +225,3 @@ chmod a-x %{buildroot}%{_includedir}/tqscintilla/*.h
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 2:1.7.1-1
-- Initial release for TDE 14.0.0