summaryrefslogtreecommitdiffstats
path: root/redhat/dependencies/tqscintilla/tqscintilla.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/dependencies/tqscintilla/tqscintilla.spec')
-rw-r--r--redhat/dependencies/tqscintilla/tqscintilla.spec103
1 files changed, 37 insertions, 66 deletions
diff --git a/redhat/dependencies/tqscintilla/tqscintilla.spec b/redhat/dependencies/tqscintilla/tqscintilla.spec
index 95fec75d2..e306fb57b 100644
--- a/redhat/dependencies/tqscintilla/tqscintilla.spec
+++ b/redhat/dependencies/tqscintilla/tqscintilla.spec
@@ -18,12 +18,9 @@
# TDE variables
%define tde_epoch 2
%if "%{?tde_version}" == ""
-%define tde_version 14.0.9
+%define tde_version 14.0.13
%endif
%define tde_pkg tqscintilla
-%define tde_prefix /opt/trinity
-%define tde_datadir %{tde_prefix}/share
-%define tde_tdedocdir %{tde_datadir}/doc/tde
%if 0%{?mdkversion} || 0%{?mgaversion} || 0%{?pclinuxos}
%define libtqscintilla %{_lib}tqscintilla
@@ -58,9 +55,10 @@ Source1: trinity-tqscintilla-rpmlintrc
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-filesystem >= %{tde_version}
+BuildRequires: trinity-cmake >= %{tde_version}
BuildRequires: desktop-file-utils
-BuildRequires: gettext
BuildRequires: gcc-c++
+BuildRequires: gettext
%description
Scintilla is a free source code editing component. It has features found
@@ -94,7 +92,6 @@ TQScintilla is a port or Scintilla to the TQt GUI toolkit.
%defattr(-,root,root,-)
%doc ChangeLog LICENSE NEWS README
%{_libdir}/libqscintilla.so.7
-%{_libdir}/libqscintilla.so.7.0
%{_libdir}/libqscintilla.so.7.0.1
%{_libdir}/tqt3/plugins/designer/*.so
%dir %{_datadir}/tqt3/translations/
@@ -120,9 +117,11 @@ This package contains the development files for tqscintilla.
%files -n %{libtqscintilla}-devel
%defattr(-,root,root,-)
-%doc doc/Scintilla example
%{_includedir}/tqscintilla/
%{_libdir}/libqscintilla.so
+%{_libdir}/pkgconfig/qscintilla.pc
+%exclude %{_libdir}/libqscintilla.la
+%exclude %{_libdir}/tqt3/plugins/designer/*.la
##########
@@ -138,7 +137,7 @@ This package contains the documentation for tqscintilla.
%files -n %{libtqscintilla}-doc
%defattr(-,root,root,-)
-%{tde_tdedocdir}/HTML/en/%{name}/
+/usr/share/doc/libtqscintilla/
##########
@@ -151,74 +150,46 @@ This package contains the documentation for tqscintilla.
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-# Fix path in project files
-%__sed -i "qt/qscintilla.pro" \
- -e "s|^INCLUDEPATH = .*|INCLUDEPATH = . ../include ../src /usr/include/tqt /usr/include/tqt3|" \
- -e "s|^header.path = .*|header.path = %{_includedir}/tqt3|" \
- -e "s|^trans.path = .*|trans.path = %{_datadir}/tqt3/translations|"
-
-%__sed -i "designer/designer.pro" \
- -e "s|\$(QTDIR)|%{_libdir}/tqt3|" \
- -e "s|# DESTDIR|DESTDIR|"
-
-export QTDIR=%{_libdir}/tqt3
-export TQTDIR=%{_prefix}
-( cd qt; tqmake "DESTDIR=$PWD/../tmplib" )
-( cd designer; tqmake )
-
%build
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
-# Workaround strange tqmake behaviour in RHEL5
-%if 0%{?rhel} == 5
-%__sed -i "qt/Makefile" -e "s|..\/..\/..\/..\/..|%{_prefix}|g"
-%endif
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
-export QTDIR=%{_libdir}/tqt3
-export TQTDIR=%{_prefix}
-%__make %{?_smp_mflags} -C qt
-%__make %{?_smp_mflags} -C designer
+%cmake \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
+ -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS}" \
+ -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS}" \
+ -DCMAKE_NO_BUILTIN_CHRPATH=ON \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DWITH_GCC_VISIBILITY=ON \
+ \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON" \
+ ..
+
+%__make %{?_smp_mflags} || %__make
%install
-unset QTDIR QTINC QTLIB
-export QTDIR=%{_libdir}/tqt3
-export TQTDIR=%{_prefix}
-%__rm -rf $RPM_BUILD_ROOT
+%__rm -rf %{?buildroot}
+%__make install -C build DESTDIR=%{?buildroot}
+
+# Fix doc location
+if [ -d %{?buildroot}%{_docdir}/lib64tqscintilla7 ]; then
+ %__mv -f %{?buildroot}%{_docdir}/lib64tqscintilla7 %{?buildroot}%{_docdir}/libtqscintilla7
+fi
+if [ -d %{?buildroot}%{_docdir}/libtqscintilla7-1.7.1 ]; then
+ %__mv -f %{?buildroot}%{_docdir}/libtqscintilla7-1.7.1 %{?buildroot}%{_docdir}/libtqscintilla7
+fi
+
-# Installs the QT part
-%__make INSTALL_ROOT=$RPM_BUILD_ROOT -C qt install
-
-# Installs supplementary headers
-for i in include/*.h; do
- %__install -D -m 644 $i %{buildroot}${QTINC}/private/${i##*/}
-done
-
-# Installs the HTML documentation correctly
-for i in doc/html/*; do
- %__install -D -m 644 $i %{buildroot}%{tde_tdedocdir}/HTML/en/%{name}/${i##*/}
-done
-
-# Installs the Designer plugin
-for i in designer/*.so ${QTDIR}/plugins/designer/*.so ${TQTDIR}/plugins/designer/*.so; do
- [ -r "${i}" ] || continue
- %__install -D -m 644 $i %{buildroot}${QTDIR}/plugins/designer/${i##*/}
-done
-
-# Installs libraries
-%__mkdir_p %{buildroot}%{_libdir}
-%__mv -f tmplib/* %{buildroot}%{_libdir}
-
-# Fix private headers location
-%__mkdir_p %{buildroot}%{_includedir}
-%__mv -f %{buildroot}/private %{buildroot}%{_includedir}/tqt3
-%__mv -f %{buildroot}%{_includedir}/tqt3 %{buildroot}%{_includedir}/tqscintilla
-
-# Fix permissions
-chmod a-x %{buildroot}%{_includedir}/tqscintilla/*.h
-chmod a-x %{buildroot}%{_includedir}/tqscintilla/*.h
+# Fix headers location
+%__mv "%{?buildroot}%{_includedir}/tqt3" "%{?buildroot}%{_includedir}/tqscintilla"
%clean