summaryrefslogtreecommitdiffstats
path: root/redhat/extras/kdevmon/kdevmon.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/extras/kdevmon/kdevmon.spec')
-rw-r--r--redhat/extras/kdevmon/kdevmon.spec150
1 files changed, 150 insertions, 0 deletions
diff --git a/redhat/extras/kdevmon/kdevmon.spec b/redhat/extras/kdevmon/kdevmon.spec
new file mode 100644
index 000000000..b2aab09f9
--- /dev/null
+++ b/redhat/extras/kdevmon/kdevmon.spec
@@ -0,0 +1,150 @@
+#
+# spec file for package kdevmon (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# Default version for this component
+%define tde_pkg kdevmon
+%if "%{?tde_version}" == ""
+%define tde_version 14.0.7
+%endif
+
+# TDE specific building variables
+%define tde_bindir %{tde_prefix}/bin
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+%define tde_appdir %{tde_datadir}/applications
+
+%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdedocdir %{tde_docdir}/tde
+%define tde_tdeincludedir %{tde_includedir}/tde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+%define _docdir %{tde_docdir}
+
+
+Name: trinity-%{tde_pkg}
+Summary: A utility for monitoring the throughput of one network device
+Version: 0.4.6
+Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+
+License: GPLv2+
+Group: Applications/Utilities
+
+Vendor: Trinity Project
+Packager: Francois Andriot <francois.andriot@free.fr>
+URL: http://www.trinitydesktop.org/
+
+Prefix: %{_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0: %{tde_pkg}-%{tde_version}.tar.gz
+
+BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
+BuildRequires: trinity-arts-devel >= 2:1.5.10
+BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+BuildRequires: trinity-tdebase-devel >= %{tde_version}
+BuildRequires: desktop-file-utils
+
+BuildRequires: gettext
+
+
+%description
+Kdevmon is a utility for TDE that monitors the throughput of a network device.
+It docks in Kicker (the panel of TDE) and shows the current network traffic
+as a diagram. There also is a resizable main window that provides a larger
+traffic diagram and displays the current net speed in bits per second.
+Middle-clicking on the dock window or on the main window offers
+you an overview of the amount of incoming/outgoing bits and the current and
+the maximum bit rate.
+
+%if 0%{?suse_version} || 0%{?pclinuxos}
+%debug_package
+%endif
+
+
+%prep
+%setup -q -n %{tde_pkg}-%{version}
+
+%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
+%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__make -f "admin/Makefile.common"
+
+
+%build
+unset QTDIR QTINC QTLIB
+export PATH="%{tde_bindir}:${PATH}"
+
+%configure \
+ --prefix=%{tde_prefix} \
+ --exec-prefix=%{tde_prefix} \
+ --bindir=%{tde_bindir} \
+ --datadir=%{tde_datadir} \
+ --docdir=%{tde_tdedocdir} \
+ --includedir=%{tde_tdeincludedir} \
+ --libdir=%{tde_libdir} \
+ --mandir=%{tde_mandir} \
+ \
+ --disable-dependency-tracking \
+ --disable-debug \
+ --enable-new-ldflags \
+ --enable-final \
+ --enable-closure \
+ --enable-rpath \
+ --disable-gcc-hidden-visibility
+
+%__make %{?_smp_mflags} || %__make
+
+
+%install
+export PATH="%{tde_bindir}:${PATH}"
+%__rm -rf %{buildroot}
+%__make install DESTDIR=%{buildroot}
+
+
+%clean
+%__rm -rf %{buildroot}
+
+
+%post
+for f in locolor ; do
+ touch --no-create %{tde_datadir}/icons/${f} || :
+ gtk-update-icon-cache --quiet %{tde_datadir}/icons/${f} || :
+done
+/sbin/ldconfig
+
+
+%postun
+for f in locolor ; do
+ touch --no-create %{tde_datadir}/icons/${f} || :
+ gtk-update-icon-cache --quiet %{tde_datadir}/icons/${f} || :
+done
+/sbin/ldconfig
+
+
+%files
+%defattr(-,root,root,-)
+%doc AUTHORS COPYING
+%{tde_bindir}/kdevmon
+%{tde_datadir}/applnk/Internet/kdevmon.desktop
+%{tde_tdedocdir}/HTML/en/kdevmon/
+%{tde_datadir}/icons/locolor/16x16/apps/kdevmon.png
+%{tde_datadir}/icons/locolor/32x32/apps/kdevmon.png
+
+
+%changelog