summaryrefslogtreecommitdiffstats
path: root/redhat/extras/klibido/klibido.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/extras/klibido/klibido.spec')
-rw-r--r--redhat/extras/klibido/klibido.spec143
1 files changed, 143 insertions, 0 deletions
diff --git a/redhat/extras/klibido/klibido.spec b/redhat/extras/klibido/klibido.spec
new file mode 100644
index 000000000..86a8323cd
--- /dev/null
+++ b/redhat/extras/klibido/klibido.spec
@@ -0,0 +1,143 @@
+#
+# spec file for package klibido (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# Default version for this component
+%define tde_pkg klibido
+%if "%{?tde_version}" == ""
+%define tde_version 14.0.7
+%endif
+
+# TDE specific building variables
+%define tde_bindir %{tde_prefix}/bin
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+%define tde_appdir %{tde_datadir}/applications
+
+%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdedocdir %{tde_docdir}/tde
+%define tde_tdeincludedir %{tde_includedir}/tde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+%define _docdir %{tde_docdir}
+
+Name: trinity-%{tde_pkg}
+Summary: A TDE usenet news grabber for Linux.
+Version: 0.2.5
+Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+
+License: GPL
+Group: Applications/Network
+
+Vendor: Trinity Project
+Packager: Francois Andriot <francois.andriot@free.fr>
+URL: http://klibido.sourceforge.net/
+
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0: %{tde_pkg}-%{tde_version}.tar.gz
+
+BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
+BuildRequires: trinity-arts-devel >= 2:1.5.10
+BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+BuildRequires: trinity-tdebase-devel >= %{tde_version}
+BuildRequires: desktop-file-utils
+
+BuildRequires: uulib-devel
+
+
+%description
+KLibido is a TDE program to download encoded articles from the usenet news
+service, using the nntp protocol. It supports multiple servers, multiple
+download threads per server, automatic joining and decoding of articles.
+
+KLibido is not a NewsReader. It doesn't let you easily display the articles -
+only their subject, and it discards all non-binary posts. If you want a nice
+newsreader for TDE, try KNode.
+
+%files
+%defattr(-,root,root)
+%doc AUTHORS ChangeLog COPYING INSTALL NEWS README RELEASE TODO
+%{tde_bindir}/klibido
+%{tde_tdeappdir}/klibido.desktop
+%{tde_datadir}/apps/klibido/
+%{tde_datadir}/doc/tde/HTML/en/klibido/
+%{tde_datadir}/icons/hicolor/*/apps/klibido.png
+%lang(fr) %{tde_datadir}/locale/fr/LC_MESSAGES/klibido.mo
+
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
+%debug_package
+%endif
+
+##########
+
+%prep
+%setup -q -n %{tde_pkg}-%{version}
+
+%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
+%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__make -f "admin/Makefile.common"
+
+
+%build
+unset QTDIR QTINC QTLIB
+export PATH="%{tde_bindir}:${PATH}"
+
+if [ -r /usr/include/db53/db_cxx.h ]; then
+ EXTRA_INCLUDES="/usr/include/db53"
+fi
+
+%configure \
+ --prefix=%{tde_prefix} \
+ --exec-prefix=%{tde_prefix} \
+ --bindir=%{tde_bindir} \
+ --datadir=%{tde_datadir} \
+ --includedir=%{tde_tdeincludedir} \
+ \
+ --disable-dependency-tracking \
+ --disable-debug \
+ --enable-final \
+ --enable-new-ldflags \
+ --enable-closure \
+ --enable-rpath \
+ --disable-gcc-hidden-visibility \
+ \
+ --with-extra-includes=%{_includedir}/uulib:${EXTRA_INCLUDES}
+
+%__make %{?_smp_mflags} || %__make
+
+
+%install
+%__rm -rf $RPM_BUILD_ROOT
+%__make install DESTDIR=$RPM_BUILD_ROOT
+
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+%suse_update_desktop_file klibido News
+%endif
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%changelog