summaryrefslogtreecommitdiffstats
path: root/redhat/libraries/python-trinity/python-trinity-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/libraries/python-trinity/python-trinity-14.0.0.spec')
-rw-r--r--redhat/libraries/python-trinity/python-trinity-14.0.0.spec126
1 files changed, 71 insertions, 55 deletions
diff --git a/redhat/libraries/python-trinity/python-trinity-14.0.0.spec b/redhat/libraries/python-trinity/python-trinity-14.0.0.spec
index 4b19fb540..f969038f9 100644
--- a/redhat/libraries/python-trinity/python-trinity-14.0.0.spec
+++ b/redhat/libraries/python-trinity/python-trinity-14.0.0.spec
@@ -1,53 +1,68 @@
+#
+# spec file for package python-trinity (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
-%endif
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
-
-# TDE specific building variables
+%endif
+%define tde_pkg python-trinity
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/kde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
-%define tde_tdelibdir %{tde_libdir}/trinity
-
-%define _docdir %{tde_docdir}
-%define __arch_install_post %{nil}
-
-Name: trinity-python-trinity
-Summary: Trinity bindings for Python [Trinity]
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
Version: 3.16.3
-Release: %{?!preversion:6}%{?preversion:5_%{preversion}}%{?dist}%{?_variant}
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: Trinity bindings for Python
+Group: Development/Libraries/Python
+URL: http://www.trinitydesktop.org/
+#URL: http://www.simonzone.com/software/pykdeextensions
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
License: GPLv2+
-Group: Applications/Utilities
+%endif
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-#URL: http://www.simonzone.com/software/pykdeextensions
-URL: http://www.trinitydesktop.org/
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
-Prefix: %{_prefix}
+Prefix: %{tde_prefix}
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+
BuildRequires: desktop-file-utils
BuildRequires: gettext
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
# PYTHON support
BuildRequires: python
@@ -58,19 +73,27 @@ Requires: python-tqt
BuildRequires: sip4-tqt-devel >= 4.10.5
Requires: sip4-tqt >= 4.10.5
-Obsoletes: python-trinity < %{version}-%{release}
-Provides: python-trinity = %{version}-%{release}
+Obsoletes: python-trinity < %{?epoch:%{epoch}:}%{version}-%{release}
+Provides: python-trinity = %{?epoch:%{epoch}:}%{version}-%{release}
%description
Python binding module that provides wide access to the Trinity API,
also known as PyTDE. Using this, you'll get (for example) classes
from tdeio, tdejs, tdehtml and tdeprint.
+%files
+%defattr(-,root,root,-)
+%doc AUTHORS ChangeLog COPYING NEWS README
+%{python_sitearch}/*.so
+%{python_sitearch}/dcop*.py*
+%{python_sitearch}/pytde*.py*
+
+##########
%package devel
-Summary: Trinity bindings for Python - Development files and scripts [Trinity]
-Group: Development/Libraries
-Requires: %{name} = %{version}-%{release}
+Summary: Trinity bindings for Python - Development files and scripts
+Group: Development/Libraries/Python
+Requires: %{name} = %{?epoch:%{epoch}:}%{version}-%{release}
Obsoletes: python-trinity-devel < %{version}-%{release}
Provides: python-trinity-devel = %{version}-%{release}
@@ -82,23 +105,36 @@ packages based on them.
The package also contains kdepyuic, a wrapper script around PyQt's
user interface compiler.
+%files devel
+%defattr(-,root,root,-)
+%{tde_bindir}/tdepyuic
+# The SIP files are outside TDE's prefix
+%{_datadir}/sip/trinity/
+
+##########
%package doc
-Summary: Documentation and examples for PyTDE [Trinity]
-Group: Development/Libraries
+Summary: Documentation and examples for PyTDE
+Group: Development/Libraries/Python
-Obsoletes: python-trinity-doc < %{version}-%{release}
-Provides: python-trinity-doc = %{version}-%{release}
+Obsoletes: python-trinity-doc < %{?epoch:%{epoch}:}%{version}-%{release}
+Provides: python-trinity-doc = %{?epoch:%{epoch}:}%{version}-%{release}
%description doc
General documentation and examples for PyTDE providing programming
tips and working code you can use to learn from.
+%files doc
+%defattr(-,root,root,-)
+%{tde_tdedocdir}/HTML/en/python-trinity/
+
+##########
-%if 0%{?suse_version} || 0%{?pclinuxos}
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
@@ -133,24 +169,4 @@ export PATH="%{tde_bindir}:${PATH}"
%__rm -rf %{buildroot}
-%files
-%defattr(-,root,root,-)
-%doc AUTHORS ChangeLog COPYING NEWS README
-%{python_sitearch}/*.so
-%{python_sitearch}/dcop*.py*
-%{python_sitearch}/pytde*.py*
-
-%files devel
-%defattr(-,root,root,-)
-%{tde_bindir}/tdepyuic
-# The SIP files are outside TDE's prefix
-%{_datadir}/sip/trinity/
-
-%files doc
-%defattr(-,root,root,-)
-%{tde_tdedocdir}/HTML/en/python-trinity/
-
-
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 3.16.3-5
-- Initial release for TDE 14.0.0