summaryrefslogtreecommitdiffstats
path: root/redhat/main/tdetoys/tdetoys-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/main/tdetoys/tdetoys-14.0.0.spec')
-rw-r--r--redhat/main/tdetoys/tdetoys-14.0.0.spec85
1 files changed, 65 insertions, 20 deletions
diff --git a/redhat/main/tdetoys/tdetoys-14.0.0.spec b/redhat/main/tdetoys/tdetoys-14.0.0.spec
index 3b6385237..5f3fa0fc9 100644
--- a/redhat/main/tdetoys/tdetoys-14.0.0.spec
+++ b/redhat/main/tdetoys/tdetoys-14.0.0.spec
@@ -1,46 +1,82 @@
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
-%endif
-
+#
+# spec file for package tdetoys (version R14.0.0)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http:/www.trinitydesktop.org/
+#
+
+# BUILD WARNING:
+# Remove qt-devel and qt3-devel and any kde*-devel on your system !
+# Having KDE libraries may cause FTBFS here !
+
+# TDE variables
%define tde_version 14.0.0
-
-# TDE specific building variables
+%define tde_pkg tdetoys
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
-
%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
+# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
+%if "%{?tde_prefix}" != "/usr"
+%define _variant .opt
+%endif
+Name: trinity-%{tde_pkg}
Summary: Trinity Desktop Environment - Toys and Amusements
-Name: trinity-tdetoys
-Group: Amusements/Graphics
Version: %{tde_version}
Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+Group: Amusements/Graphics
+URL: http://www.trinitydesktop.org/
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
License: GPLv2+
-Source0: %{name}-%{version}%{?preversion:~%{preversion}}.tar.gz
+%endif
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-URL: http://www.trinitydesktop.org/
+#Vendor: Trinity Project
+#Packager: Francois Andriot <francois.andriot@free.fr>
Prefix: %{tde_prefix}
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: cmake >= 2.8
-BuildRequires: desktop-file-utils
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
+# Trinity dependencies
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+
+BuildRequires: cmake >= 2.8
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: fdupes
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+BuildRequires: desktop-file-utils
BuildRequires: gettext
Obsoletes: trinity-kdetoys < %{version}-%{release}
@@ -371,7 +407,7 @@ update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
##########
-%if 0%{?suse_version} || 0%{?pclinuxos}
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
@@ -421,6 +457,15 @@ export PATH="%{tde_bindir}:${PATH}"
# Useless include file from Amor
%__rm -f %{buildroot}%{tde_tdeincludedir}/AmorIface.h
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+%suse_update_desktop_file -r kworldclock Utility Clock
+%suse_update_desktop_file -r kteatime Applet
+%suse_update_desktop_file -r amor Amusement
+%suse_update_desktop_file -r kodo Amusement
+%suse_update_desktop_file ktux Screensaver
+%endif
+
%clean
%__rm -rf %{buildroot}