summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/adept/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/adept/debian/rules')
-rwxr-xr-xubuntu/_base/applications/adept/debian/rules24
1 files changed, 4 insertions, 20 deletions
diff --git a/ubuntu/_base/applications/adept/debian/rules b/ubuntu/_base/applications/adept/debian/rules
index 2618af2fc..83626c5cb 100755
--- a/ubuntu/_base/applications/adept/debian/rules
+++ b/ubuntu/_base/applications/adept/debian/rules
@@ -1,8 +1,10 @@
#!/usr/bin/make -f
+# Currently is not possible to build piklab with --enable-final
+DEB_BUILD_OPTIONS += noopt
+
include /usr/share/cdbs/1/rules/debhelper.mk
-include debian/cdbs/kde.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include debian/cdbs/debian-tde.mk
DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
@@ -14,24 +16,6 @@ cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xine
DEB_MAKE_CHECK_TARGET := check
DEB_CONFIGURE_EXTRA_FLAGS += --enable-adept --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
# Enable us to locate the old libept-trinity library and includes
CPPFLAGS += -I/opt/trinity/include
LDFLAGS += -L/opt/trinity/lib -lept
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
-# Store build information
-common-binary-post-install-arch common-binary-post-install-indep::