summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/filelight/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/filelight/debian')
-rw-r--r--ubuntu/_base/applications/filelight/debian/cdbs/debian-tde.mk10
-rwxr-xr-xubuntu/_base/applications/filelight/debian/rules8
2 files changed, 10 insertions, 8 deletions
diff --git a/ubuntu/_base/applications/filelight/debian/cdbs/debian-tde.mk b/ubuntu/_base/applications/filelight/debian/cdbs/debian-tde.mk
index 641c6c6cc..5b4e8bfd7 100644
--- a/ubuntu/_base/applications/filelight/debian/cdbs/debian-tde.mk
+++ b/ubuntu/_base/applications/filelight/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
diff --git a/ubuntu/_base/applications/filelight/debian/rules b/ubuntu/_base/applications/filelight/debian/rules
index d9ef0cae3..7bc15fb33 100755
--- a/ubuntu/_base/applications/filelight/debian/rules
+++ b/ubuntu/_base/applications/filelight/debian/rules
@@ -8,11 +8,6 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
DEB_DH_ALWAYS_EXCLUDE=.svn
# Build options
@@ -26,6 +21,3 @@ DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
-DCMAKE_SKIP_RPATH="OFF" \
-DBUILD_ALL="ON"
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)