summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/fusion-icon/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/fusion-icon/debian/rules')
-rwxr-xr-xubuntu/_base/applications/fusion-icon/debian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/fusion-icon/debian/rules b/ubuntu/_base/applications/fusion-icon/debian/rules
index 46359aca2..a0c6906dd 100755
--- a/ubuntu/_base/applications/fusion-icon/debian/rules
+++ b/ubuntu/_base/applications/fusion-icon/debian/rules
@@ -12,8 +12,15 @@ else
endif
#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
post-patches::
# make sure that python binary exists