summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/internet/kftpgrabber/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/internet/kftpgrabber/debian/rules')
-rwxr-xr-xubuntu/_base/applications/internet/kftpgrabber/debian/rules30
1 files changed, 12 insertions, 18 deletions
diff --git a/ubuntu/_base/applications/internet/kftpgrabber/debian/rules b/ubuntu/_base/applications/internet/kftpgrabber/debian/rules
index 8292bc38c..a6797f19a 100755
--- a/ubuntu/_base/applications/internet/kftpgrabber/debian/rules
+++ b/ubuntu/_base/applications/internet/kftpgrabber/debian/rules
@@ -1,23 +1,17 @@
#!/usr/bin/make -f
-# Currently is not possible to build with --enable-final
-DEB_BUILD_OPTIONS += noopt
-
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-build/kftpgrabber-trinity::
- /usr/bin/docbook2x-man debian/kftpgrabber.xml
-
-binary-install/kftpgrabber-trinity::
- install -D -p -m644 debian/kftpgrabber-trinity.lintian-overrides \
- debian/kftpgrabber-trinity/usr/share/lintian/overrides/kftpgrabber-trinity
- mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
-
-clean::
- rm -f kftpgrabber.1
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"