summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/k3b/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/k3b/debian/rules')
-rwxr-xr-xubuntu/_base/applications/k3b/debian/rules18
1 files changed, 1 insertions, 17 deletions
diff --git a/ubuntu/_base/applications/k3b/debian/rules b/ubuntu/_base/applications/k3b/debian/rules
index f4f5b0012..e40095080 100755
--- a/ubuntu/_base/applications/k3b/debian/rules
+++ b/ubuntu/_base/applications/k3b/debian/rules
@@ -1,8 +1,7 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include debian/cdbs/kde.mk
+include debian/cdbs/debian-tde.mk
DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde5
DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
@@ -16,18 +15,3 @@ DEB_CONFIGURE_EXTRA_FLAGS = --with-k3bsetup=no --with-extra-libs=/opt/trinity/li
DEB_INSTALL_MANPAGES_k3b = debian/k3b.1
DEB_MAKE_INSTALL_TARGET := install DESTDIR=$(CURDIR)/debian/tmp/
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap