summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/kmyfirewall/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/kmyfirewall/debian/rules')
-rwxr-xr-xubuntu/_base/applications/kmyfirewall/debian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/kmyfirewall/debian/rules b/ubuntu/_base/applications/kmyfirewall/debian/rules
new file mode 100755
index 000000000..bae3f5cf7
--- /dev/null
+++ b/ubuntu/_base/applications/kmyfirewall/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-qt-kde.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+binary-install/kmyfirewall-trinity::
+ rm -f debian/$(cdbs_curpkg)/opt/trinity/lib/*.so
+ mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
+ chmod +x debian/$(cdbs_curpkg)/opt/trinity/share/apps/kmyfirewall/scripts/installer/linux/*.sh