summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/krename/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/krename/debian/rules')
-rwxr-xr-xubuntu/_base/applications/krename/debian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/krename/debian/rules b/ubuntu/_base/applications/krename/debian/rules
new file mode 100755
index 000000000..18b1c07e2
--- /dev/null
+++ b/ubuntu/_base/applications/krename/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include debian/cdbs/debian-qt-kde.mk
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"