summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/multimedia/k9copy/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/multimedia/k9copy/debian/rules')
-rwxr-xr-xubuntu/_base/applications/multimedia/k9copy/debian/rules50
1 files changed, 12 insertions, 38 deletions
diff --git a/ubuntu/_base/applications/multimedia/k9copy/debian/rules b/ubuntu/_base/applications/multimedia/k9copy/debian/rules
index aca7b475b..a6797f19a 100755
--- a/ubuntu/_base/applications/multimedia/k9copy/debian/rules
+++ b/ubuntu/_base/applications/multimedia/k9copy/debian/rules
@@ -1,43 +1,17 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_INSTALL_MANPAGES_k9copy = k9copy-trinity.1
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --includedir="/opt/trinity/include/tde" --mandir="/opt/trinity/share/man" --infodir="/opt/trinity/share/info" --enable-k3bdevices
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
-install/k9copy-trinity::
- dh_installman k9copy.1
- mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
- dh_link opt/trinity/share/doc/tde/HTML/en/k9copy usr/share/doc/$(cdbs_curpkg)/html
-
-build/k9copy-trinity::
- docbook2x-man debian/k9copy.1.docbook
-
-clean::
- rm -f k9copy.1
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"