summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/system/tdepowersave/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/system/tdepowersave/debian/rules')
-rwxr-xr-xubuntu/_base/applications/system/tdepowersave/debian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/system/tdepowersave/debian/rules b/ubuntu/_base/applications/system/tdepowersave/debian/rules
new file mode 100755
index 000000000..58af3504b
--- /dev/null
+++ b/ubuntu/_base/applications/system/tdepowersave/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_GCC_VISIBILITY="ON"
+
+install/tdepowersave-trinity::
+ install -p -D -m644 debian/tdepowersave-trinity.lintian debian/tdepowersave-trinity/usr/share/lintian/overrides/tdepowersave-trinity