summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/themes/qt4-tqt-theme-engine/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/themes/qt4-tqt-theme-engine/debian/rules')
-rwxr-xr-xubuntu/_base/applications/themes/qt4-tqt-theme-engine/debian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/themes/qt4-tqt-theme-engine/debian/rules b/ubuntu/_base/applications/themes/qt4-tqt-theme-engine/debian/rules
new file mode 100755
index 000000000..11c6e4544
--- /dev/null
+++ b/ubuntu/_base/applications/themes/qt4-tqt-theme-engine/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/class/qmake.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+QMAKE := qmake-qt4