summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/yakuake/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/yakuake/debian/rules')
-rwxr-xr-xubuntu/_base/applications/yakuake/debian/rules24
1 files changed, 2 insertions, 22 deletions
diff --git a/ubuntu/_base/applications/yakuake/debian/rules b/ubuntu/_base/applications/yakuake/debian/rules
index f86dc62d5..2bbfee612 100755
--- a/ubuntu/_base/applications/yakuake/debian/rules
+++ b/ubuntu/_base/applications/yakuake/debian/rules
@@ -1,7 +1,7 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
-include debian/cdbs/kde.mk
+include debian/cdbs/debian-tde.mk
DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
@@ -9,28 +9,8 @@ DEB_CONFIGURE_PREFIX := /opt/trinity
DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
+
#There is not any interesting doc to install.
INSTALL_DOCS_ALL :=
DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-### Libtool and Automake updates
-post-patches:: debian/stamp-autothings-update
-debian/stamp-autothings-update:
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
-
- touch $@
-
-clean::
- rm -f debian/stamp-autothings-update
-