summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/core/tdevelop/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/core/tdevelop/debian/rules')
-rwxr-xr-xubuntu/_base/core/tdevelop/debian/rules44
1 files changed, 0 insertions, 44 deletions
diff --git a/ubuntu/_base/core/tdevelop/debian/rules b/ubuntu/_base/core/tdevelop/debian/rules
index 5f91d36a7..833ff7ecc 100755
--- a/ubuntu/_base/core/tdevelop/debian/rules
+++ b/ubuntu/_base/core/tdevelop/debian/rules
@@ -13,55 +13,11 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
DEB_DH_STRIP_ARGS := --dbg-package=tdevelop-trinity-dbg
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
PACKAGES_WITH_LIBS := tdevelop-trinity
DEB_KDE_APIDOX := yes
-DEB_KDE_ENABLE_FINAL :=
-DEB_INSTALL_DOCS_tdevelop = AUTHORS
-DEB_MAKE_INSTALL_TARGET := install DESTDIR=$(CURDIR)/debian/tmp
-DEB_CONFIGURE_EXTRA_FLAGS := \
- --disable-debug \
- --enable-docbase \
- --enable-scripting \
- --enable-ada \
- --enable-bash \
- --enable-cpp \
- --enable-fortran \
- --enable-haskell \
- --enable-java \
- --enable-pascal \
- --enable-perl \
- --enable-php \
- --enable-python \
- --enable-ruby \
- --enable-sql \
- --enable-antproject \
- --enable-autoproject \
- --enable-customproject \
- --enable-genericproject \
- --enable-scriptproject \
- --enable-trollproject \
- --enable-cvs \
- --enable-vba \
- --enable-subversion \
- --with-pic \
- --with-tdelibsdoxy-dir=/opt/trinity/share/doc/tde/HTML/en/tdelibs-apidocs \
- --with-pythondir=/usr \
-# --with-qtdoc-dir=/usr/share/tqt3/doc/html \
- --prefix=/opt/trinity \
- --with-extra-libs=/opt/trinity/lib
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \