summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/arts/debian/cdbs
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/dependencies/arts/debian/cdbs')
-rw-r--r--ubuntu/_base/dependencies/arts/debian/cdbs/debian-qt-kde.mk27
-rw-r--r--ubuntu/_base/dependencies/arts/debian/cdbs/versions.pl19
2 files changed, 46 insertions, 0 deletions
diff --git a/ubuntu/_base/dependencies/arts/debian/cdbs/debian-qt-kde.mk b/ubuntu/_base/dependencies/arts/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..65f5f6f95
--- /dev/null
+++ b/ubuntu/_base/dependencies/arts/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,27 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+
+endif
diff --git a/ubuntu/_base/dependencies/arts/debian/cdbs/versions.pl b/ubuntu/_base/dependencies/arts/debian/cdbs/versions.pl
new file mode 100644
index 000000000..75c9add4b
--- /dev/null
+++ b/ubuntu/_base/dependencies/arts/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";