summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/sip4-tqt/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/dependencies/sip4-tqt/debian/control')
-rw-r--r--ubuntu/_base/dependencies/sip4-tqt/debian/control83
1 files changed, 50 insertions, 33 deletions
diff --git a/ubuntu/_base/dependencies/sip4-tqt/debian/control b/ubuntu/_base/dependencies/sip4-tqt/debian/control
index bdd8f4eb0..2c7df285c 100644
--- a/ubuntu/_base/dependencies/sip4-tqt/debian/control
+++ b/ubuntu/_base/dependencies/sip4-tqt/debian/control
@@ -4,60 +4,79 @@ Priority: optional
Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
XSBC-Original-Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Uploaders: Torsten Marek <shlomme@debian.org>, Bernd Zeimetz <bzed@debian.org>, Michael Casadevall <mcasadevall@debian.org>
-Build-Depends: debhelper (>= 9~), python-all-dev (>= 2.3.5-10), python-all-dbg, python-support (>= 0.7.1) | dh-python, libtqtinterface-dev
+Build-Depends: debhelper (>= 10~), python3-all-dev, python3-all-dbg, dh-python, libtqtinterface-dev, bison, flex
Standards-Version: 3.8.4
XS-Python-Version: all
+X-Python3-Version: >= 3.0
-Package: python-sip-tqt
+Package: python3-sip-tqt
Architecture: any
Section: python
-Replaces: python-sip-tqt (<< 4:14.0.0~)
-Breaks: python-sip-tqt (<< 4:14.0.0~)
-Provides: ${python:Provides}, sip-tqt-api-7.1, sip-api-7.1
-Depends: ${python:Depends}, ${shlibs:Depends}, ${misc:Depends}
-Conflicts: python-sip4 (<< 4.10)
-Description: Python/C++ bindings generator runtime library
- SIP is a tool for generating bindings for C++ classes with some ideas
+Provides: ${python3:Provides}
+Depends: ${python3:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Description: Python 3/C++ bindings generator runtime library
+ SIP-TQt is a tool for generating bindings for C++ classes with some ideas
borrowed from SWIG, but capable of tighter bindings because of its
specificity towards C++ and Python.
+ .
+ This package provides the SIP-TQt module for Python 3
-Package: python-sip-tqt-dbg
-Priority: extra
+Package: python3-sip-tqt-dev
+Architecture: any
+Section: python
+Depends: ${python3:Depends}, python3-sip-tqt (= ${binary:Version}), sip-tqt-dev, python3-all-dev, ${shlibs:Depends}, libjs-jquery, ${misc:Depends}
+Description: Python/C++ bindings generator development files
+ SIP-TQt is a tool for generating bindings for C++ classes with some ideas
+ borrowed from SWIG, but capable of tighter bindings because of its
+ specificity towards C++ and Python.
+ .
+ SIP-TQt was originally designed to generate Python bindings for TDE and so
+ has explicit support for the signal slot mechanism used by the TQt/TDE
+ class libraries.
+ .
+ Features:
+ - connecting TQt signals to Python functions and class methods
+ - connecting Python signals to TQt slots
+ - overloading virtual member functions with Python class methods
+ - protected member functions
+ - abstract classes
+ - enumerated types
+ - global class instances
+ - static member functions.
+ .
+ This package contains the code generator tool and the development headers
+ needed to develop Python 3 bindings with sip-tqt.
+
+Package: python3-sip-tqt-dbg
Architecture: any
-Replaces: python-sip-tqt-dbg (<< 4:14.0.0~)
-Breaks: python-sip-tqt-dbg (<< 4:14.0.0~)
Section: debug
-Provides: ${python:Provides}
-Depends: python-sip-tqt (= ${binary:Version}), python-all-dbg, ${shlibs:Depends}, ${misc:Depends}
-Conflicts: python-sip4-dbg (<< 4.10)
-Description: Python/C++ bindings generator runtime library (debug extension)
- SIP is a tool for generating bindings for C++ classes with some ideas
+Priority: extra
+Depends: python3-sip-tqt (= ${binary:Version}), python3-all-dbg, ${shlibs:Depends}, ${misc:Depends}
+Description: Python 3/C++ bindings generator runtime library
+ SIP-TQt is a tool for generating bindings for C++ classes with some ideas
borrowed from SWIG, but capable of tighter bindings because of its
specificity towards C++ and Python.
.
- This package contains the extension built for the Python debug interpreter.
+ This package provides the SIP-TQt module for the debug build of the Python 3.
-Package: python-sip-tqt-dev
+Package: sip-tqt-dev
Architecture: any
Section: python
-Replaces: python-sip-tqt-dev (<< 4:14.0.0~)
-Breaks: python-sip-tqt-dev (<< 4:14.0.0~)
-Depends: ${python:Depends}, python-sip-tqt (= ${binary:Version}), python-all-dev, ${shlibs:Depends}, libjs-jquery, ${misc:Depends}
-Recommends: python-sip-tqt (>= ${source:Version})
-Provides: python-sip-dev, python-sip4-dev, sip4
-Conflicts: python-sip-dev, python-sip4-dev (<< 4.10), sip4 (<< 4.10)
+Depends: ${python3:Depends}, ${shlibs:Depends}
+Breaks: python-sip-tqt-dev (<< 4:14.1.0~)
+Recommends: python3-sip-tqt-dev
Description: Python/C++ bindings generator development files
- SIP is a tool for generating bindings for C++ classes with some ideas
+ SIP-TQt is a tool for generating bindings for C++ classes with some ideas
borrowed from SWIG, but capable of tighter bindings because of its
specificity towards C++ and Python.
.
- SIP was originally designed to generate Python bindings for TDE and so
+ SIP-TQt was originally designed to generate Python bindings for TDE and so
has explicit support for the signal slot mechanism used by the TQt/TDE
class libraries.
.
Features:
- - connecting Qt signals to Python functions and class methods
- - connecting Python signals to Qt slots
+ - connecting TQt signals to Python functions and class methods
+ - connecting Python signals to TQt slots
- overloading virtual member functions with Python class methods
- protected member functions
- abstract classes
@@ -65,6 +84,4 @@ Description: Python/C++ bindings generator development files
- global class instances
- static member functions.
.
- This package contains the code generator tool and the development headers
- needed to develop Python bindings with sip.
-
+ This package contains the code generator tool needed to develop Python 3 bindings with sip-tqt.