summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/tqtinterface/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/dependencies/tqtinterface/debian/rules')
-rwxr-xr-xubuntu/_base/dependencies/tqtinterface/debian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/ubuntu/_base/dependencies/tqtinterface/debian/rules b/ubuntu/_base/dependencies/tqtinterface/debian/rules
index 1b9c978a0..1e56fa6e0 100755
--- a/ubuntu/_base/dependencies/tqtinterface/debian/rules
+++ b/ubuntu/_base/dependencies/tqtinterface/debian/rules
@@ -7,9 +7,16 @@ include debian/cdbs/debian-tde.mk
version=Debian Package $(DEB_VERSION)
DEB_OPT_FLAG += -DDEBIAN_VERSION=$(DEB_VERSION)
+ifdef DEB_HOST_MULTIARCH
+ CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
+else
+ CMAKE_INSTALL_LIBDIR = lib
+endif
+
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_LIBDIR=$(CMAKE_INSTALL_LIBDIR) \
-DWITH_QT3="ON"