summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/libraries/libksquirrel/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/libraries/libksquirrel/debian/rules')
-rwxr-xr-xubuntu/_base/libraries/libksquirrel/debian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/ubuntu/_base/libraries/libksquirrel/debian/rules b/ubuntu/_base/libraries/libksquirrel/debian/rules
index 15f00b785..d761aa0a1 100755
--- a/ubuntu/_base/libraries/libksquirrel/debian/rules
+++ b/ubuntu/_base/libraries/libksquirrel/debian/rules
@@ -16,8 +16,15 @@ DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)