summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/libraries/pytdeextensions/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/libraries/pytdeextensions/debian/rules')
-rwxr-xr-xubuntu/_base/libraries/pytdeextensions/debian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/ubuntu/_base/libraries/pytdeextensions/debian/rules b/ubuntu/_base/libraries/pytdeextensions/debian/rules
index e4c433701..28a7627ba 100755
--- a/ubuntu/_base/libraries/pytdeextensions/debian/rules
+++ b/ubuntu/_base/libraries/pytdeextensions/debian/rules
@@ -29,6 +29,12 @@ DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinit
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+post-patches::
+ # make sure that python binary exists
+ # since the existing code is still dependent on python2
+ # and cdbs uses python as the default binary name
+ test -x /usr/bin/python || ln -s python2 /usr/bin/python
+
install/pytdeextensions-trinity::
# We have no idea if the built product is site-packages or dist-packages
cd debian/tmp/usr/lib/python*/ && mv site-packages/ dist-packages/ || echo "site-packages --> dist-packages"