summaryrefslogtreecommitdiffstats
path: root/ubuntu/lucid_automake/applications/digikam/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/lucid_automake/applications/digikam/debian/rules')
-rwxr-xr-xubuntu/lucid_automake/applications/digikam/debian/rules41
1 files changed, 0 insertions, 41 deletions
diff --git a/ubuntu/lucid_automake/applications/digikam/debian/rules b/ubuntu/lucid_automake/applications/digikam/debian/rules
deleted file mode 100755
index 6d17f8853..000000000
--- a/ubuntu/lucid_automake/applications/digikam/debian/rules
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/simple-patchsys.mk
-include /usr/share/cdbs/1/rules/utils.mk
-include debian/cdbs/debian-qt-kde.mk
--include /usr/share/gnome-pkg-tools/1/rules/sf-get-source.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/kde3/include/kde
-DEB_CONFIGURE_MANDIR := /opt/kde3/share/man
-DEB_CONFIGURE_PREFIX := /opt/kde3
-DEB_CONFIGURE_INFODIR := /opt/kde3/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-TARBALL_EXT=tar.bz2
-
-DEB_CONFIGURE_EXTRA_FLAGS := --without-included-sqlite3 --prefix=/opt/kde3 --disable-static
-
-DEB_CONFIGURE_SCRIPT_ENV += LDFLAGS="-Wl,--as-needed"
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/opt/kde3/lib)
-
-PKG_CONFIG_PATH=/opt/kde3/lib/pkgconfig:$PKG_CONFIG_PATH
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-install/digikam-kde3::
- # remove empty API-docs dirs tree
- rm -rf $(CURDIR)/debian/digikam-kde3/opt/kde3/share/doc/kde