summaryrefslogtreecommitdiffstats
path: root/ubuntu/lucid_automake/applications/gtk-qt-engine/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/lucid_automake/applications/gtk-qt-engine/debian/rules')
-rwxr-xr-xubuntu/lucid_automake/applications/gtk-qt-engine/debian/rules32
1 files changed, 32 insertions, 0 deletions
diff --git a/ubuntu/lucid_automake/applications/gtk-qt-engine/debian/rules b/ubuntu/lucid_automake/applications/gtk-qt-engine/debian/rules
new file mode 100755
index 000000000..56eb66129
--- /dev/null
+++ b/ubuntu/lucid_automake/applications/gtk-qt-engine/debian/rules
@@ -0,0 +1,32 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/kde3/include/kde
+DEB_CONFIGURE_MANDIR := /opt/kde3/share/man
+DEB_CONFIGURE_PREFIX := /opt/kde3
+DEB_CONFIGURE_INFODIR := /opt/kde3/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/kde3 --with-extra-libs=/opt/kde3/lib
+
+configure/gtk-qt-engine-kde3::
+ env PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/kde cmake -D CMAKE_INSTALL_PREFIX=/opt/kde3 .
+
+build/gtk-qt-engine-kde3::
+ env PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/kde $(MAKE)
+
+install/gtk-qt-engine-kde3::
+ env PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/kde $(MAKE) install DESTDIR=$(CURDIR)/debian/gtk-qt-engine-kde3
+ mkdir -p $(CURDIR)/debian/gtk-qt-engine-kde3/opt/kde3/share/kgtk/
+ cp -Rp $(CURDIR)/debian/.gtkrc-2.0-kde4 $(CURDIR)/debian/gtk-qt-engine-kde3/opt/kde3/share/kgtk/
+ cp -Rp $(CURDIR)/debian/.gtkrc-2.0-kde-kde4 $(CURDIR)/debian/gtk-qt-engine-kde3/opt/kde3/share/kgtk/
+ cp -Rp $(CURDIR)/debian/gtk-qt-engine.rc.sh $(CURDIR)/debian/gtk-qt-engine-kde3/opt/kde3/share/kgtk/