summaryrefslogtreecommitdiffstats
path: root/ubuntu/lucid_automake/applications/k9copy/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/lucid_automake/applications/k9copy/debian')
-rw-r--r--ubuntu/lucid_automake/applications/k9copy/debian/cdbs/buildvars.mk86
-rw-r--r--ubuntu/lucid_automake/applications/k9copy/debian/cdbs/debian-qt-kde.mk109
-rw-r--r--ubuntu/lucid_automake/applications/k9copy/debian/cdbs/kde.mk97
-rw-r--r--ubuntu/lucid_automake/applications/k9copy/debian/cdbs/team-members16
-rw-r--r--ubuntu/lucid_automake/applications/k9copy/debian/cdbs/uploaders.mk29
-rw-r--r--ubuntu/lucid_automake/applications/k9copy/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/lucid_automake/applications/k9copy/debian/changelog112
-rw-r--r--ubuntu/lucid_automake/applications/k9copy/debian/compat2
-rw-r--r--ubuntu/lucid_automake/applications/k9copy/debian/control17
-rw-r--r--ubuntu/lucid_automake/applications/k9copy/debian/copyright38
-rw-r--r--ubuntu/lucid_automake/applications/k9copy/debian/k9copy.1.docbook113
-rw-r--r--ubuntu/lucid_automake/applications/k9copy/debian/patches/.gitignore0
-rwxr-xr-xubuntu/lucid_automake/applications/k9copy/debian/rules38
13 files changed, 0 insertions, 676 deletions
diff --git a/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/buildvars.mk b/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/buildvars.mk
deleted file mode 100644
index 23d4709dc..000000000
--- a/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/buildvars.mk
+++ /dev/null
@@ -1,86 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2002,2003 Colin Walters <walters@debian.org>
-# Description: Defines some useful variables, but no rules
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-
-ifndef _cdbs_rules_buildvars
-_cdbs_rules_buildvars = 1
-
-CDBS_VERSION = something
-
-# Common useful variables
-DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
-DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
-DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
-DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
-DEB_ISNATIVE := $(shell dpkg-parsechangelog | egrep '^Version:' | perl -ne 'print if not /^Version:\s*.*-/;')
-
-# Split into arch/indep packages
-ifneq ($(DEB_INDEP_PACKAGES),cdbs)
-DEB_INDEP_PACKAGES := $(filter-out $(DONT_BUILD), $(strip $(shell $(_cdbs_scripts_path)/list-packages indep)))
-DEB_ARCH_PACKAGES := $(filter-out $(DONT_BUILD), $(filter-out $(DEB_INDEP_PACKAGES),$(strip $(shell $(_cdbs_scripts_path)/list-packages same))))
-endif
-# Split into normal and udeb packages
-ifeq ($(DEB_UDEB_PACKAGES),)
-DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-DEB_UDEB_PACKAGES = $(filter-out $(DONT_BUILD),$(filter %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-else
-DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES), $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-endif
-# Too much bother for now. If someone complains we'll fix it.
-#DEB_ARCH_UDEB_PACKAGES = $(filter %-udeb, $(DEB_ARCH_PACKAGES))
-#DEB_INDEP_UDEB_PACKAGES = $(filter %-udeb, $(DEB_INDEP_PACKAGES))
-# A handy list of every package, udeb or not
-DEB_ALL_PACKAGES = $(filter-out $(DONT_BUILD),$(DEB_PACKAGES) $(DEB_UDEB_PACKAGES))
-DEB_INDEP_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_INDEP_PACKAGES)))
-DEB_ARCH_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_ARCH_PACKAGES)))
-
-DEB_DBG_PACKAGES = $(filter-out $(DONT_BUILD), $(filter %-dbg, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-
-# Some support for srcdir != builddir builds.
-# These are relative to the root of the package
-DEB_SRCDIR ?= .
-DEB_BUILDDIR ?= $(strip $(DEB_SRCDIR))
-
-# Miscellaneous bits
-DEB_ARCH = $(shell dpkg --print-architecture)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
-DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
-DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
-DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
-DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
-DEB_BUILD_GNU_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_CPU)
-DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-DEB_BUILD_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
-DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
-
-ifeq ($(words $(DEB_ALL_PACKAGES)),1)
- DEB_DESTDIR = $(CURDIR)/debian/$(strip $(DEB_ALL_PACKAGES))/
-else
- DEB_DESTDIR = $(CURDIR)/debian/tmp/
-endif
-
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), cdbs (>= 0.4.23-1.1)
-
-endif
diff --git a/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/debian-qt-kde.mk b/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/debian-qt-kde.mk
deleted file mode 100644
index 2be8f97f1..000000000
--- a/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/debian-qt-kde.mk
+++ /dev/null
@@ -1,109 +0,0 @@
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
- touch debian/stamp-cvs-make
-
-include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
-include debian/cdbs/uploaders.mk
-
-DEB_PATCHDIRS := debian/patches/common debian/patches
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/kde3/share/doc/kde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/kde3/share/doc/kde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/kde3/share/doc/kde/HTML/en/$$pkg; \
- /opt/kde3/bin/meinproc $(DEB_DESTDIR)/opt/kde3/share/doc/kde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/kde3/share/doc/kde/HTML/en/$$pkg; \
- done
-
-clean::
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/kde.mk b/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/kde.mk
deleted file mode 100644
index 9e4117558..000000000
--- a/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/kde.mk
+++ /dev/null
@@ -1,97 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Description: A class for KDE packages; sets KDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-
-ifndef _cdbs_class_kde
-_cdbs_class_kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/kde3
-export kde_htmldir = \$${datadir}/doc/kde/HTML
-
-ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/kde"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-common-build-arch common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-prehook-impl::
- mkdir -p po
- -XGETTEXT=/usr/bin/kde-xgettext EXTRACTATTR=/opt/kde3/bin/extractattr sh $(DEB_SRCDIR)/admin/cvs.sh extract-messages
- -for file in po/*pot; do \
- sed "s/charset=CHARSET/charset=UTF-8/" -i $$file; \
- done
-
-common-install-arch common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-clean::
- rm -f debian/stamp-kde-apidox
- rm -rf po/*.pot
-
-# This is a convenience target for calling manually. It's not part of
-# the build process.
-buildprep: clean apply-patches
- $(MAKE) -f admin/Makefile.common dist
- debian/rules clean
-
-endif
diff --git a/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/team-members b/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/team-members
deleted file mode 100644
index 05761af6e..000000000
--- a/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/team-members
+++ /dev/null
@@ -1,16 +0,0 @@
-Sune Vuorela <debian@pusling.com>
-Ana Beatriz Guerrero Lopez <ana@debian.org>
-Fathi Boudra <fboudra@free.fr>
-Modestas Vainius <geromanas@mailas.com>
-Josh Metzler <joshdeb@metzlers.org>
-Isaac Clerencia <isaac@debian.org>
-Adeodato Simó <dato@net.com.org.es>
-Adeodato Simo <dato@net.com.org.es>
-Christopher Martin <chrsmrtn@debian.org>
-Daniel Schepler <schepler@debian.org>
-Sarah Hobbs <hobbsee@ubuntu.com>
-Nacho Barrientos Arias <nacho@debian.org>
-Ricardo Javier Cardenes Medina <rcardenes@debian.org>
-Ricardo Cardenes <rcardenes@debian.org>
-Armin Berres <trigger+debian@space-based.de>
-Francesco Pedrini <francesco.pedrini@gmail.com>
diff --git a/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/uploaders.mk b/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/uploaders.mk
deleted file mode 100644
index 31adfe31e..000000000
--- a/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/uploaders.mk
+++ /dev/null
@@ -1,29 +0,0 @@
-
-MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
-UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
-
-
-debian/control.tmp:
- @if [ ! -e debian/control.in ] ; then \
- echo "this package is not yet prepared for using automatic update of uploaders"; \
- echo "Please do so."; \
- exit 1; \
- fi
- @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
-
-check-uploaders: debian/control.tmp
- @if ! diff -q debian/control debian/control.tmp ; then \
- echo "WARNING:: Control file differs from manually generated one" ; \
- echo "WARNING:: Please update it manually and check it afterwards" ; \
- echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
- echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
- fi
-
-
-clean::
- rm -f debian/control.tmp
-
-update-uploaders: debian/control.tmp
- @mv -f debian/control.tmp debian/control
-
-makebuilddir:: check-uploaders
diff --git a/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/versions.pl b/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/versions.pl
deleted file mode 100644
index 9ce11d8a3..000000000
--- a/ubuntu/lucid_automake/applications/k9copy/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/-[^-]+$//;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "KDE-Version3=$version3\n";
-print "KDE-Version2=$version2\n";
-print "KDE-Next-Version3=$version3_next\n";
-print "KDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/lucid_automake/applications/k9copy/debian/changelog b/ubuntu/lucid_automake/applications/k9copy/debian/changelog
deleted file mode 100644
index db2fab08a..000000000
--- a/ubuntu/lucid_automake/applications/k9copy/debian/changelog
+++ /dev/null
@@ -1,112 +0,0 @@
-k9copy-kde3 (1.2.3-0ubuntu2) karmic; urgency=low
-
- * Karmic rebuild
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 July 2009 16:08:00 -0600
-
-k9copy-kde3 (1.2.3-0ubuntu1) intrepid; urgency=low
-
- * Added -kde3 suffix
- * Changed prefix to /opt/kde3
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 08 Apr 2000 10:46:00 -0600
-
-k9copy (1.2.3-0ubuntu1) hardy; urgency=low
-
- * New upstream release.
- * debian/patches/kubuntu_05_typo_fix.patch: dropped, included upstream
-
- -- Luka Renko <lure@ubuntu.com> Sun, 20 Jan 2008 16:38:59 +0100
-
-k9copy (1.2.2-0ubuntu1) hardy; urgency=low
-
- * New upstream release.
- * Moved Homepage field to source stanza.
- * Removed kubuntu_01_kdepot.diff - no longer need (upstream updated
- admin).
-
- -- Jonathan Patrick Davies <jpatrick@kubuntu.org> Mon, 31 Dec 2007 16:40:34 +0100
-
-k9copy (1.2.1-0ubuntu2) hardy; urgency=low
-
- * debian/patches:
- - Added kubuntu_05_typo_fix.patch to fix a typo error (LP: #177715)
- * debian/control
- - Bump Standards-Version to 3.7.3
- - Added autotools-dev as Build-Depends to avoid the following lintian
- error: outdated-autotools-helper-file admin/config.{guess,sub}
-
- -- Miguel Ruiz <mruiz@ubuntu.com> Wed, 26 Dec 2007 12:32:26 -0300
-
-k9copy (1.2.1-0ubuntu1) hardy; urgency=low
-
- * New upstream release
- * debian/control:
- * Build-Depends on libdvdread-dev (was libdvdread3-dev)
- * Build-Depends on libavformat-dev & libavcodec-dev
- * debian/patches/kubuntu_04_fix_header_files_inclusion.patch:
- * Dropped, as it is resolved upstream
- * debian/patches/kubuntu_04_fix_libGL_crash.patch:
- * fix crash when libGL.so is not present, instead ask for
- versioned name, libGL.so.1 (LP: #174752)
-
- -- Luka Renko <lure@ubuntu.com> Sun, 16 Dec 2007 12:34:12 +0100
-
-k9copy (1.1.3-0ubuntu2) gutsy; urgency=low
-
- * Update upstream web site address (LP: #139193)
- * Change maintainer to MOTU
-
- -- Scott Kitterman <scott@kitterman.com> Wed, 12 Sep 2007 15:22:36 -0400
-
-k9copy (1.1.3-0ubuntu1) gutsy; urgency=low
-
- * New upstream release
- * kubuntu_03_fix_Makefile_files_in_po_directory.patch: updated to apply
-
- -- Luka Renko <lure@ubuntu.com> Thu, 16 Aug 2007 16:42:33 +0200
-
-k9copy (1.1.2-0ubuntu1) gutsy; urgency=low
-
- * New upstream release
- * debian/control: add Build-Depends on DBus and HAL
- * kubuntu_02_fix_desktop_file.patch: drop, fixed upstream
- * kubuntu_03_fix_Makefile_files_in_po_directory.patch: updated to apply
- * kubuntu_04_fix_header_files_inclusion.patch: updated to apply
-
- -- Luka Renko <lure@ubuntu.com> Sun, 12 Aug 2007 21:59:39 +0200
-
-k9copy (1.1.0~beta2-0ubuntu1) feisty; urgency=low
-
- * New upstream release
- * Bump Standards-Version
-
- -- Adrien Cunin <adri2000@gmail.com> Wed, 29 Nov 2006 16:30:24 +0100
-
-k9copy (1.1.0~beta1-0ubuntu2) edgy; urgency=low
-
- * Added dependency on libdvdnav and mencoder
-
- -- Anthony Mercatante <tonio@ubuntu.com> Tue, 17 Oct 2006 02:19:52 +0200
-
-k9copy (1.1.0~beta1-0ubuntu1) edgy; urgency=low
-
- * New upstream release
- * Added kubuntu_04_fix_header_files_inclusion.patch to fix progress.h file
- inclusion in k9progress.h file
-
- -- Anthony Mercatante <tonio@ubuntu.com> Tue, 11 Jul 2006 22:10:52 +0200
-
-k9copy (1.0.2-0ubuntu1) dapper; urgency=low
-
- * Initial Release.
- * Added kubuntu_01_kdepot for pot file inclusion in Rosetta.
- * Added kubuntu_02_fix_desktop_file to add french and english GenericName,
- and Categories to K9copy.desktop file.
- * Added kubuntu_03_fix_Makefile_files_in_po_directory to fix po/Makefile.am
- and po/Makefile.in. k9copy.pot entry needs to be removed for the
- application to build.
- * Tarball rebuild to correct permissions, too many files were executable.
- * Sponsored upload for Anthony Mercatante <anthony.mercatante@laposte.net>
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 28 Dec 2005 13:46:20 +0200
diff --git a/ubuntu/lucid_automake/applications/k9copy/debian/compat b/ubuntu/lucid_automake/applications/k9copy/debian/compat
deleted file mode 100644
index 51d7b8d16..000000000
--- a/ubuntu/lucid_automake/applications/k9copy/debian/compat
+++ /dev/null
@@ -1,2 +0,0 @@
-5
-
diff --git a/ubuntu/lucid_automake/applications/k9copy/debian/control b/ubuntu/lucid_automake/applications/k9copy/debian/control
deleted file mode 100644
index 631f47989..000000000
--- a/ubuntu/lucid_automake/applications/k9copy/debian/control
+++ /dev/null
@@ -1,17 +0,0 @@
-Source: k9copy-kde3
-Section: kde
-Priority: optional
-Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
-XSBC-Original-Maintainer: Anthony Mercatante <tonio@ubuntu.com>
-Build-Depends: debhelper (>= 5), cdbs, kdelibs4-kde3-dev, docbook2x, libdvdread-dev, libdbus-1-dev, libhal-dev, libhal-storage-dev, libavformat-dev, automake1.11-kde3, autoconf2.63, libtool, libltdl-dev
-Standards-Version: 3.8.3
-Homepage: http://k9copy.sourceforge.net/
-
-Package: k9copy-kde3
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, vamps, dvd+rw-tools, dvdauthor, mencoder, libdvdnav4
-Description: DVD backup tool for KDE3
- k9copy is a tabbed tool that allows to copy of one or more titles from a DVD9
- to a DVD5, in the same way than DVDShrink for Microsoft Windows (R).
- This is the KDE3 version
-
diff --git a/ubuntu/lucid_automake/applications/k9copy/debian/copyright b/ubuntu/lucid_automake/applications/k9copy/debian/copyright
deleted file mode 100644
index c08901dd0..000000000
--- a/ubuntu/lucid_automake/applications/k9copy/debian/copyright
+++ /dev/null
@@ -1,38 +0,0 @@
-This package was debianized by Anthony Mercatante <anthony.mercatante@laposte.net> on
-Fri, 28 Dec 2005 13:18:00 +0200.
-
-It was downloaded from http://k9copy.free.fr
-
-Upstream Author:
- Jean-Michel Petit <jm_petit@laposte.net>
-
-License:
-
-All the software and debian/k9copy.1.docbook:
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this package; if not, write to the Free Software Foundation,
- Inc., 51 Franklin St, Fifth Floor, Boston, N: MA 02110-1301, USA.
-
- On Debian GNU/Linux systems, the complete text of the GNU General
- Public License can be found in `/usr/share/common-licenses/GPL'.
-
-Copyright:
-
-All the software:
-
- Copyright (C) 2005 by Jean-Michel Petit <jm_petit@laposte.net>
-
-debian/k9copy.1.docbook:
-
- Copyright (C) 2005 by Anthony Mercatante <anthony.mercatante@laposte.net>
diff --git a/ubuntu/lucid_automake/applications/k9copy/debian/k9copy.1.docbook b/ubuntu/lucid_automake/applications/k9copy/debian/k9copy.1.docbook
deleted file mode 100644
index ff14d9107..000000000
--- a/ubuntu/lucid_automake/applications/k9copy/debian/k9copy.1.docbook
+++ /dev/null
@@ -1,113 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
-"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
-]>
-<refentry>
- <refentryinfo>
- <author>
- <firstname>Mercatante</firstname>
- <surname>Anthony</surname>
- <email>anthony.mercatante@laposte.net</email>
- </author>
- <copyright>
- <year>2005</year>
- <holder>Anthony Mercatante</holder>
- </copyright>
- <!-- XXX IMPORTANT XXX -->
- <!-- Keep this date up to date: -->
- <date>2005-07-28</date>
- <!-- ^^^^^^^^^^ -->
- </refentryinfo>
- <refmeta>
- <refentrytitle>k9copy</refentrytitle>
- <manvolnum>1</manvolnum>
- </refmeta>
- <refnamediv>
- <refname>k9copy</refname>
- <refpurpose>DVD copy tool for KDE</refpurpose>
- </refnamediv>
- <refsynopsisdiv>
- <cmdsynopsis>
- <command>k9copy</command>
- <arg choice="opt">
- <option><replaceable>Qt-options</replaceable></option>
- </arg>
- <arg choice="opt">
- <option><replaceable>KDE-options</replaceable></option>
- </arg>
- </cmdsynopsis>
- </refsynopsisdiv>
- <refsect1>
- <title>DESCRIPTION</title>
- <para>
- DVD copy tool for KDE.
- </para>
- <para>
- k9copy is a DVD backup utility which allow the copy of one or more titles from a DVD9 to a DVD5.
- </para>
- </refsect1>
- <refsect1>
- <title>OPTIONS</title>
- <para>
- All <productname>KDE</productname> and <productname>Qt</productname>
- programs accept a some common command-line options. k9copy has no
- application-specific options.
- </para>
- <para>
- <variablelist>
- <title>Generic options:</title>
- <varlistentry>
- <term> <option>--help</option> </term>
- <listitem> <para>Show help about options</para> </listitem>
- </varlistentry>
- <varlistentry>
- <term> <option>--help-qt</option> </term>
- <listitem> <para>Show Qt specific options</para> </listitem>
- </varlistentry>
- <varlistentry>
- <term> <option>--help-kde</option> </term>
- <listitem> <para>Show KDE specific options</para> </listitem>
- </varlistentry>
- <varlistentry>
- <term> <option>--help-all</option> </term>
- <listitem> <para>Show all options</para> </listitem>
- </varlistentry>
- <varlistentry>
- <term> <option>--author</option> </term>
- <listitem> <para>Show author information</para> </listitem>
- </varlistentry>
- <varlistentry>
- <term> <option>-v</option>, <option>--version</option> </term>
- <listitem> <para>Show version information</para> </listitem>
- </varlistentry>
- <varlistentry>
- <term> <option>--license</option> </term>
- <listitem> <para>Show license information</para> </listitem>
- </varlistentry>
- <varlistentry>
- <term> <option>--</option> </term>
- <listitem> <para>Indicates end of options</para> </listitem>
- </varlistentry>
- </variablelist>
- <!-- TODO * add all the rest of the options, but maybe find an automated
- way to keep it up to date -->
- </para>
- </refsect1>
- <refsect1>
- <title>COPYRIGHT</title>
- <para>
- This manual page was written by Anthony Mercatante
- <email>anthony.mercatante@laposte.net</email> for the
- <productname>Debian</productname> system (but may be used by others).
- Permission is granted to copy, distribute and/or modify this document
- under the terms of the <acronym>GNU</acronym> General Public License,
- Version 2 or any later version published by the Free Software Foundation.
- </para>
- <para>
- On Debian systems, the complete text of the GNU General Public
- License can be found in
- <filename>/usr/share/common-licenses/GPL</filename>.
- </para>
- </refsect1>
-</refentry>
-
diff --git a/ubuntu/lucid_automake/applications/k9copy/debian/patches/.gitignore b/ubuntu/lucid_automake/applications/k9copy/debian/patches/.gitignore
deleted file mode 100644
index e69de29bb..000000000
--- a/ubuntu/lucid_automake/applications/k9copy/debian/patches/.gitignore
+++ /dev/null
diff --git a/ubuntu/lucid_automake/applications/k9copy/debian/rules b/ubuntu/lucid_automake/applications/k9copy/debian/rules
deleted file mode 100755
index 4fbc09fd4..000000000
--- a/ubuntu/lucid_automake/applications/k9copy/debian/rules
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/simple-patchsys.mk
-include /usr/share/cdbs/1/class/kde.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/kde3/include/kde
-DEB_CONFIGURE_MANDIR := /opt/kde3/share/man
-DEB_CONFIGURE_PREFIX := /opt/kde3
-DEB_CONFIGURE_INFODIR := /opt/kde3/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_INSTALL_MANPAGES_k9copy = k9copy-kde3.1
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/kde3 --includedir="/opt/kde3/include/kde" --mandir="/opt/kde3/share/man" --infodir="/opt/kde3/share/info"
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
-install/k9copy::
- dh_install src/k9copy.desktop opt/kde3/share/applications/kde
- dh_link usr/share/doc/kde/HTML/en/k9copy usr/share/doc/k9copy/html
-
-build/k9copy::
- docbook2x-man debian/k9copy.1.docbook
-
-clean::
- rm -f k9copy.1