summaryrefslogtreecommitdiffstats
path: root/ubuntu/lucid_automake/applications/kgtk-qt3/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/lucid_automake/applications/kgtk-qt3/debian/rules')
-rwxr-xr-xubuntu/lucid_automake/applications/kgtk-qt3/debian/rules31
1 files changed, 0 insertions, 31 deletions
diff --git a/ubuntu/lucid_automake/applications/kgtk-qt3/debian/rules b/ubuntu/lucid_automake/applications/kgtk-qt3/debian/rules
deleted file mode 100755
index 8abf4e1bb..000000000
--- a/ubuntu/lucid_automake/applications/kgtk-qt3/debian/rules
+++ /dev/null
@@ -1,31 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/simple-patchsys.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/kde3/include/kde
-DEB_CONFIGURE_MANDIR := /opt/kde3/share/man
-DEB_CONFIGURE_PREFIX := /opt/kde3
-DEB_CONFIGURE_INFODIR := /opt/kde3/share/info
-DEB_CMAKE_CUSTOM_FLAGS := -DKGTK_KDE3=true -DKGTK_QT3=true
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/kde3 --with-extra-libs=/opt/kde3/lib
-
-configure/kgtk-qt3-kde3::
- env PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/kde cmake -D CMAKE_INSTALL_PREFIX=/opt/kde3 .
-
-build/kgtk-qt3-kde3::
- env PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/kde $(MAKE)
-
-install/kgtk-qt3-kde3::
- env PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/kde $(MAKE) install DESTDIR=$(CURDIR)/debian/kgtk-qt3-kde3
- mkdir -p $(CURDIR)/debian/kgtk-qt3-kde3/opt/kde3/share/kgtk/
- cp -Rp $(CURDIR)/debian/preload $(CURDIR)/debian/kgtk-qt3-kde3/opt/kde3/share/kgtk/