summaryrefslogtreecommitdiffstats
path: root/ubuntu/lucid_automake/applications/kmplayer/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/lucid_automake/applications/kmplayer/debian/rules')
-rwxr-xr-xubuntu/lucid_automake/applications/kmplayer/debian/rules46
1 files changed, 0 insertions, 46 deletions
diff --git a/ubuntu/lucid_automake/applications/kmplayer/debian/rules b/ubuntu/lucid_automake/applications/kmplayer/debian/rules
deleted file mode 100755
index 7f45f88c3..000000000
--- a/ubuntu/lucid_automake/applications/kmplayer/debian/rules
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/simple-patchsys.mk
-include debian/cdbs/kde.mk
-include /usr/share/cdbs/1/rules/utils.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/kde3/include/kde
-DEB_CONFIGURE_MANDIR := /opt/kde3/share/man
-DEB_CONFIGURE_PREFIX := /opt/kde3
-DEB_CONFIGURE_INFODIR := /opt/kde3/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-_P=)
-GCC_VERSION := $(shell gcc --version | sed -n "/^gcc/s/^[^$(_P)]*$(_P) \(.\..\).*/\1/p")
-ifeq ($(GCC_VERSION),4.3)
- CXX = g++ -fpermissive
-endif
-
-DEB_CONFIGURE_EXTRA_FLAGS := --enable-maintainer-mode --prefix=/opt/kde3 --with-extra-libs=/opt/kde3/lib --with-extra-includes=/opt/kde3/include/kde
-DEB_DH_INSTALL_ARGS = --sourcedir=debian/tmp
-DEB_INSTALL_MANPAGES_kmplayer = kmplayer.1
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
-build/kmplayer-kde3::
- docbook2x-man debian/kmplayer.1.docbook
-
-clean::
- rm -f kmplayer.1
-
-get-orig-source-dpatch:
- @@dh_testdir
- @@[ -d ../tarballs/. ]
- @@dpatch-get-origtargz ../tarballs