summaryrefslogtreecommitdiffstats
path: root/ubuntu/lucid_automake/applications/kmyfirewall/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/lucid_automake/applications/kmyfirewall/debian/rules')
-rwxr-xr-xubuntu/lucid_automake/applications/kmyfirewall/debian/rules131
1 files changed, 131 insertions, 0 deletions
diff --git a/ubuntu/lucid_automake/applications/kmyfirewall/debian/rules b/ubuntu/lucid_automake/applications/kmyfirewall/debian/rules
new file mode 100755
index 000000000..e0333883c
--- /dev/null
+++ b/ubuntu/lucid_automake/applications/kmyfirewall/debian/rules
@@ -0,0 +1,131 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/kde3/include/kde
+DEB_CONFIGURE_MANDIR := /opt/kde3/share/man
+DEB_CONFIGURE_PREFIX := /opt/kde3
+DEB_CONFIGURE_INFODIR := /opt/kde3/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+-include debian/debiandirs
+
+# To be used with kde-style admin subdirectories if desired.
+debian/debiandirs: admin/debianrules
+ perl -w admin/debianrules echodirs > debian/debiandirs
+
+
+config.status: configure
+ dh_testdir
+
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+ # Add here commands to configure the package.
+ifneq "$(wildcard /usr/share/misc/config.sub)" ""
+ cp -f /usr/share/misc/config.sub config.sub
+endif
+ifneq "$(wildcard /usr/share/misc/config.guess)" ""
+ cp -f /usr/share/misc/config.guess config.guess
+endif
+ CFLAGS="$(CFLAGS)" PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/kde ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) $(configkde) --prefix=/opt/kde3 --with-extra-libs=/opt/kde3/lib --with-extra-includes=/opt/kde3/include/kde
+
+
+build: build-stamp
+
+build-stamp: config.status
+ dh_testdir
+
+ # Add here commands to compile the package.
+ env PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/kde $(MAKE)
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+ # Add here commands to clean up after the build process.
+ [ ! -f Makefile ] || $(MAKE) distclean
+
+ dh_clean config.guess config.sub KMFIPTInterface/Makefile KMFSysTray/Makefile kmyfirewall/compilers/pf/Makefile
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+
+ # Add here commands to install the package into debian/kmyfirewall.
+ env PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/kde $(MAKE) install DESTDIR=$(CURDIR)/debian/kmyfirewall-kde3
+
+ rm -f debian/kmyfirewall-kde3/opt/kde3/lib/*.so
+ chrpath -d debian/kmyfirewall-kde3/opt/kde3/bin/kmyfirewall debian/kmyfirewall-kde3/opt/kde3/lib/*.so.* debian/kmyfirewall-kde3/opt/kde3/lib/kde3/*.so
+ chmod +x debian/kmyfirewall-kde3/opt/kde3/share/apps/kmyfirewall/scripts/installer/linux/*.sh
+ dh_install
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs ChangeLog
+ dh_installdocs
+ dh_installexamples
+ dh_icons
+ dh_desktop
+ dh_installmenu
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress -X.bz2 -X.css -X.dcl -X.docbook -X-license -X.tag
+ dh_fixperms
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install