summaryrefslogtreecommitdiffstats
path: root/ubuntu/lucid_automake/applications/kpicosim/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/lucid_automake/applications/kpicosim/debian/rules')
-rwxr-xr-xubuntu/lucid_automake/applications/kpicosim/debian/rules128
1 files changed, 0 insertions, 128 deletions
diff --git a/ubuntu/lucid_automake/applications/kpicosim/debian/rules b/ubuntu/lucid_automake/applications/kpicosim/debian/rules
deleted file mode 100755
index b210dc942..000000000
--- a/ubuntu/lucid_automake/applications/kpicosim/debian/rules
+++ /dev/null
@@ -1,128 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/kde3/include/kde
-DEB_CONFIGURE_MANDIR := /opt/kde3/share/man
-DEB_CONFIGURE_PREFIX := /opt/kde3
-DEB_CONFIGURE_INFODIR := /opt/kde3/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-
-config.status: configure
- dh_testdir
-
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
- # Add here commands to configure the package.
- CFLAGS="$(CFLAGS) -Wl,-z,defs" ./configure $(configkde)--host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/opt/kde3 --mandir=/opt/kde3/share/man --with-extra-libs=/opt/kde3/lib --infodir=/opt/kde3/share/info
-
-
-build: build-stamp
-
-build-stamp: config.status
- dh_testdir
-
- # Add here commands to compile the package.
- env PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/kde $(MAKE)
- #docbook-to-man debian/kpicosim.sgml > kpicosim.1
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
- # Add here commands to clean up after the build process.
- -$(MAKE) distclean
-
- dh_clean
- rm -f config.log config.guess config.sub
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package into debian/kpicosim.
- $(MAKE) install DESTDIR=$(CURDIR)/debian/kpicosim-kde3
-
- # Install standard documentation links.
- for pkg in `dh_listpackages`; do \
- if test -d debian/$$pkg/opt/kde3/share/doc/HTML; then \
- if test ! -d debian/$$pkg/opt/kde3/share/doc/kde; then \
- mkdir debian/$$pkg/opt/kde3/share/doc/kde; \
- fi; \
- mv debian/$$pkg/opt/kde3/share/doc/HTML debian/$$pkg/opt/kde3/share/doc/kde/; \
- fi; \
- if test -d debian/$$pkg/opt/kde3/share/doc/kde/HTML/en/$$pkg; then \
- dh_link -p$$pkg opt/kde3/share/doc/kde/HTML/en/$$pkg \
- opt/kde3/share/doc/$$pkg/html; \
- fi; \
- done
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installexamples
- dh_installmenu
- dh_installman
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install