summaryrefslogtreecommitdiffstats
path: root/ubuntu/lucid_automake/applications/potracegui/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/lucid_automake/applications/potracegui/debian/rules')
-rwxr-xr-xubuntu/lucid_automake/applications/potracegui/debian/rules107
1 files changed, 0 insertions, 107 deletions
diff --git a/ubuntu/lucid_automake/applications/potracegui/debian/rules b/ubuntu/lucid_automake/applications/potracegui/debian/rules
deleted file mode 100755
index 9da36fbe6..000000000
--- a/ubuntu/lucid_automake/applications/potracegui/debian/rules
+++ /dev/null
@@ -1,107 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/kde3/include/kde
-DEB_CONFIGURE_MANDIR := /opt/kde3/share/man
-DEB_CONFIGURE_PREFIX := /opt/kde3
-DEB_CONFIGURE_INFODIR := /opt/kde3/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/kde3 --with-extra-libs=/opt/kde3/lib
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
-config.status:
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
-
- dh_testdir
- CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/opt/kde3 --mandir=/opt/kde3/share/man --infodir=/opt/kde3/share/info --disable-rpath
-
-
-build: build-stamp
-
-build-stamp: config.status
- dh_testdir
- $(MAKE)
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- [ ! -f Makefile ] || $(MAKE) distclean
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess config.guess
-endif
-
- rm -f po/*.gmo
-
-
- dh_clean --exclude ./src/potracegui.cpp.orig
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k --exclude ./src/potracegui.cpp.orig
- dh_installdirs
-
- $(MAKE) install DESTDIR=$(CURDIR)/debian/potracegui-kde3
- mkdir -p $(CURDIR)/debian/potracegui-kde3/opt/kde3/share/doc/kde
- mv $(CURDIR)/debian/potracegui-kde3/opt/kde3/share/doc/HTML $(CURDIR)/debian/potracegui-kde3/opt/kde3/share/doc/kde/HTML
- mkdir -p $(CURDIR)/debian/potracegui-kde3/opt/kde3/share/applnk/Graphics
- mv $(CURDIR)/debian/potracegui-kde3/opt/kde3/share/applnk/Utilities/potracegui.desktop $(CURDIR)/debian/potracegui-kde3/opt/kde3/share/applnk/Graphics/
- rmdir $(CURDIR)/debian/potracegui-kde3/opt/kde3/share/applnk/Utilities
-
-binary-indep: build install
-
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installmenu
- dh_installman debian/potracegui-kde3.1
- dh_icons
- dh_link
- dh_strip
- dh_compress -X.docbook
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install