summaryrefslogtreecommitdiffstats
path: root/ubuntu/lucid_automake/core/kdelibs/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/lucid_automake/core/kdelibs/debian/patches')
-rw-r--r--ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_19_debianize_useragent.diff39
-rw-r--r--ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_38_no_generate_kdepot.diff14
-rw-r--r--ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_51_launchpad_integration.diff131
-rw-r--r--ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_64_rosetta_translation.diff11
4 files changed, 195 insertions, 0 deletions
diff --git a/ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_19_debianize_useragent.diff b/ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_19_debianize_useragent.diff
new file mode 100644
index 000000000..23fefb7dd
--- /dev/null
+++ b/ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_19_debianize_useragent.diff
@@ -0,0 +1,39 @@
+--- a/kio/kio/kprotocolmanager.cpp
++++ b/kio/kio/kprotocolmanager.cpp
+@@ -450,14 +450,19 @@
+ return d->useragent;
+
+ TQString supp;
++ int debian_append = 0;
+ struct utsname nam;
+ if( uname(&nam) >= 0 )
+ {
+ if( modifiers.contains('o') )
+ {
+ supp += TQString("; %1").arg(nam.sysname);
++ debian_append = 1;
+ if ( modifiers.contains('v') )
++ {
+ supp += TQString(" %1").arg(nam.release);
++ debian_append = 2;
++ }
+ }
+ if( modifiers.contains('p') )
+ {
+@@ -485,6 +490,16 @@
+ }
+ d->modifiers = modifiers;
+ d->useragent = CFG_DEFAULT_UAGENT(supp);
++
++ if (debian_append == 1)
++ d->useragent.append(" (Debian)");
++ else if (debian_append == 2)
++ {
++#define STRINGIFY(macro_or_string) STRINGIFY_ARG(macro_or_string)
++#define STRINGIFY_ARG(contents) #contents
++ d->useragent.append(" (Kubuntu package " STRINGIFY(DEBIAN_VERSION) ")");
++ }
++
+ return d->useragent;
+ }
+
diff --git a/ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_38_no_generate_kdepot.diff b/ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_38_no_generate_kdepot.diff
new file mode 100644
index 000000000..d5b892428
--- /dev/null
+++ b/ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_38_no_generate_kdepot.diff
@@ -0,0 +1,14 @@
+--- kdelibs/Makefile.am.in 2006-06-26 16:14:54.000000000 +0000
++++ kdelibs/Makefile.am.in 2006-06-26 16:16:33.000000000 +0000
+@@ -54,10 +54,8 @@
+ find $$dirs -maxdepth 1 -name "*.cc" -print >> files ;\
+ find $$dirs -maxdepth 1 -name "*.h" -print >> files ;\
+ echo ./kdecore/kde-config.cpp.in >> files ;\
+- $(EXTRACTRC) `find $$dirs -maxdepth 1 \( -name "*.rc" -o -name "*.ui" \) ` ./dnssd/kcm_kdnssd.kcfg > rc.cpp; \
+- : > kde.pot ;\
++ $(EXTRACTRC) `find $$dirs -maxdepth 1 \( -name "*.rc" -o -name "*.ui" \) ` ./dnssd/kcm_kdnssd.kcfg > rc.cpp;
+ $(XGETTEXT) -ktranslate -x qt-messages.pot rc.cpp `cat files` && cat messages.po qt-messages.pot > $(podir)/kdelibs.pot
+- $(XGETTEXT) common_texts.cpp -o kde.pot
+ rm -f dirs
+
+ EXTRA_DIST = admin kde.pot \
diff --git a/ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_51_launchpad_integration.diff b/ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_51_launchpad_integration.diff
new file mode 100644
index 000000000..b6f4e497f
--- /dev/null
+++ b/ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_51_launchpad_integration.diff
@@ -0,0 +1,131 @@
+diff -Nur kdelibs-3.5.8/kdeui/khelpmenu.cpp kdelibs-3.5.8.new/kdeui/khelpmenu.cpp
+--- kdelibs-3.5.8/kdeui/khelpmenu.cpp 2007-10-08 10:52:12.000000000 +0100
++++ kdelibs-3.5.8.new/kdeui/khelpmenu.cpp 2007-10-09 09:42:02.000000000 +0100
+@@ -41,6 +41,7 @@
+ #include <kpopupmenu.h>
+ #include <kstdaccel.h>
+ #include <kstdaction.h>
++#include <kprocess.h>
+
+ #include "kswitchlanguagedialog.h"
+
+@@ -94,6 +95,8 @@
+ KStdAction::reportBug(this, TQT_SLOT(reportBug()), actions);
+ KStdAction::aboutApp(this, TQT_SLOT(aboutApplication()), actions);
+ KStdAction::aboutKDE(this, TQT_SLOT(aboutKDE()), actions);
++ KStdAction::kubuntuTranslate(this, TQT_SLOT(kubuntuTranslate()), actions);
++ KStdAction::kubuntuGetHelpOnline(this, TQT_SLOT(kubuntuGetHelpOnline()), actions);
+ KStdAction::switchApplicationLanguage(this, TQT_SLOT(switchApplicationLanguage()), actions);
+ }
+ }
+@@ -164,6 +167,10 @@
+ if (need_separator)
+ mMenu->insertSeparator();
+
++ mMenu->insertItem( SmallIcon("launchpad"), i18n( "&Get Help Online" ), this, TQT_SLOT(kubuntuGetHelpOnline()) );
++ mMenu->insertItem( SmallIcon("locale"), i18n( "&Translate this Application" ), this, TQT_SLOT(kubuntuTranslate()) );
++ mMenu->insertSeparator();
++
+ if (kapp->authorizeKAction("help_about_app"))
+ {
+ mMenu->insertItem( kapp->miniIcon(),
+@@ -233,6 +240,24 @@
+ }
+
+
++void KHelpMenu::kubuntuGetHelpOnline()
++{
++ const KAboutData *aboutData = KGlobal::instance()->aboutData();
++ TQString path = KStandardDirs::findExe( aboutData->appName() );
++ KProcess *proc = new KProcess;
++ *proc << "launchpad-integration" << "--file" << path << "--info";
++ proc->start(KProcess::DontCare);
++}
++
++void KHelpMenu::kubuntuTranslate()
++{
++ const KAboutData *aboutData = KGlobal::instance()->aboutData();
++ TQString path = KStandardDirs::findExe( aboutData->appName() );
++ KProcess *proc = new KProcess;
++ *proc << "launchpad-integration" << "--file" << path << "--translate";
++ proc->start(KProcess::DontCare);
++}
++
+ void KHelpMenu::aboutKDE()
+ {
+ if( !mAboutKDE )
+diff -Nur kdelibs-3.5.8/kdeui/khelpmenu.h kdelibs-3.5.8.new/kdeui/khelpmenu.h
+--- kdelibs-3.5.8/kdeui/khelpmenu.h 2007-10-08 10:52:12.000000000 +0100
++++ kdelibs-3.5.8.new/kdeui/khelpmenu.h 2007-10-09 09:39:54.000000000 +0100
+@@ -219,6 +219,9 @@
+ */
+ void aboutKDE();
+
++ void kubuntuTranslate();
++ void kubuntuGetHelpOnline();
++
+ /**
+ * Opens the standard "Report Bugs" dialog box.
+ */
+diff -Nur kdelibs-3.5.8/kdeui/kstdaction.cpp kdelibs-3.5.8.new/kdeui/kstdaction.cpp
+--- kdelibs-3.5.8/kdeui/kstdaction.cpp 2007-10-08 10:52:12.000000000 +0100
++++ kdelibs-3.5.8.new/kdeui/kstdaction.cpp 2007-10-09 09:39:54.000000000 +0100
+@@ -319,5 +319,9 @@
+ { return KStdAction::create( AboutApp, name, recvr, slot, parent ); }
+ KAction *aboutKDE( const TQObject *recvr, const char *slot, KActionCollection* parent, const char *name )
+ { return KStdAction::create( AboutKDE, name, recvr, slot, parent ); }
++KAction *kubuntuTranslate( const TQObject *recvr, const char *slot, KActionCollection* parent, const char *name )
++ { return KStdAction::create( KubuntuTranslate, name, recvr, slot, parent ); }
++KAction *kubuntuGetHelpOnline( const TQObject *recvr, const char *slot, KActionCollection* parent, const char *name )
++ { return KStdAction::create( KubuntuGetHelpOnline, name, recvr, slot, parent ); }
+
+ }
+diff -Nur kdelibs-3.5.8/kdeui/kstdaction.h kdelibs-3.5.8.new/kdeui/kstdaction.h
+--- kdelibs-3.5.8/kdeui/kstdaction.h 2007-10-08 10:52:12.000000000 +0100
++++ kdelibs-3.5.8.new/kdeui/kstdaction.h 2007-10-09 09:42:41.000000000 +0100
+@@ -158,6 +158,7 @@
+ FullScreen, ///< @since 3.2
+ Clear, ///< @since 3.2
+ PasteText, ///< @since 3.2
++ KubuntuGetHelpOnline, KubuntuTranslate,
+ SwitchApplicationLanguage ///< @since 3.5.8
+ };
+
+@@ -609,6 +610,12 @@
+ */
+ KDEUI_EXPORT KAction *switchApplicationLanguage(const TQObject *recvr, const char *slot,
+ KActionCollection* parent, const char *name = 0 );
++
++ KDEUI_EXPORT KAction *kubuntuTranslate(const TQObject *recvr, const char *slot,
++ KActionCollection* parent, const char *name = 0 );
++
++ KDEUI_EXPORT KAction *kubuntuGetHelpOnline(const TQObject *recvr, const char *slot,
++ KActionCollection* parent, const char *name = 0 );
+ }
+
+ #endif // KSTDACTION_H
+diff -Nur kdelibs-3.5.8/kdeui/kstdaction_p.h kdelibs-3.5.8.new/kdeui/kstdaction_p.h
+--- kdelibs-3.5.8/kdeui/kstdaction_p.h 2007-10-08 10:52:12.000000000 +0100
++++ kdelibs-3.5.8.new/kdeui/kstdaction_p.h 2007-10-09 09:39:54.000000000 +0100
+@@ -112,6 +112,8 @@
+ { SwitchApplicationLanguage, KStdAccel::AccelNone, "switch_application_language", I18N_NOOP("Switch application &language..."), 0, 0 },
+ { AboutApp, KStdAccel::AccelNone, "help_about_app", I18N_NOOP("&About %1"), 0, 0 },
+ { AboutKDE, KStdAccel::AccelNone, "help_about_kde", I18N_NOOP("About &Trinity"), 0,"about_kde" },
++ { KubuntuGetHelpOnline, KStdAccel::AccelNone, "kubuntu_get_help_online", I18N_NOOP("&Get Help Online"), 0, "launchpad" },
++ { KubuntuTranslate, KStdAccel::AccelNone, "kubuntu_translate", I18N_NOOP("&Translate This Application"), 0, "locale" },
+ { ActionNone, KStdAccel::AccelNone, 0, 0, 0, 0 }
+ };
+
+diff -Nur kdelibs-3.5.8/kdeui/ui_standards.rc kdelibs-3.5.8.new/kdeui/ui_standards.rc
+--- kdelibs-3.5.8/kdeui/ui_standards.rc 2007-10-08 10:52:12.000000000 +0100
++++ kdelibs-3.5.8.new/kdeui/ui_standards.rc 2007-10-09 09:39:54.000000000 +0100
+@@ -178,6 +178,9 @@
+ <Separator/>
+ <Action name="switch_application_language"/>
+ <Separator/>
++ <Action name="kubuntu_get_help_online"/>
++ <Action name="kubuntu_translate"/>
++ <Separator/>
+ <MergeLocal name="about_merge"/>
+ <Action name="help_about_app"/>
+ <Action name="help_about_kde"/>
diff --git a/ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_64_rosetta_translation.diff b/ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_64_rosetta_translation.diff
new file mode 100644
index 000000000..1525f8b00
--- /dev/null
+++ b/ubuntu/lucid_automake/core/kdelibs/debian/patches/kubuntu_64_rosetta_translation.diff
@@ -0,0 +1,11 @@
+--- kdelibs/kdecore/kaboutdata.cpp 2006-03-17 10:19:05.000000000 +0000
++++ kdelibs/kdecore/kaboutdata.cpp 2006-12-05 19:46:12.000000000 +0000
+@@ -389,7 +389,7 @@
+ "of the translation teams all over the world.</p>"
+ "<p>For more information on KDE internationalization "
+ "visit <a href=\"http://l10n.kde.org\">http://l10n.kde.org</a></p>"
+- );
++ ) + i18n("<p>Kubuntu includes additions and alterations to the KDE translation from <a href=\"https://translations.launchpad.net/\">Launchpad</a>.</p>");
+ }
+
+ TQString