summaryrefslogtreecommitdiffstats
path: root/ubuntu/lucid_automake/kdeadmin/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/lucid_automake/kdeadmin/debian/rules')
-rwxr-xr-xubuntu/lucid_automake/kdeadmin/debian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/ubuntu/lucid_automake/kdeadmin/debian/rules b/ubuntu/lucid_automake/kdeadmin/debian/rules
new file mode 100755
index 000000000..569175f46
--- /dev/null
+++ b/ubuntu/lucid_automake/kdeadmin/debian/rules
@@ -0,0 +1,19 @@
+#! /usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-qt-kde.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/kde3/include/kde
+DEB_CONFIGURE_MANDIR := /opt/kde3/share/man
+DEB_CONFIGURE_PREFIX := /opt/kde3
+DEB_CONFIGURE_INFODIR := /opt/kde3/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_DH_STRIP_ARGS := --dbg-package=kdeadmin-kde3-dbg
+
+DEB_CONFIGURE_EXTRA_FLAGS := \
+ --without-rpm --with-pam=kde --with-shadow --with-nis \
+ --with-private-groups --prefix=/opt/kde3 --with-extra-libs=/opt/kde3/lib