summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/adept/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/applications/adept/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/adept/debian/rules34
1 files changed, 34 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/adept/debian/rules b/ubuntu/maverick/applications/adept/debian/rules
new file mode 100755
index 000000000..9c80b51c7
--- /dev/null
+++ b/ubuntu/maverick/applications/adept/debian/rules
@@ -0,0 +1,34 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_MAKE_CHECK_TARGET := check
+DEB_CONFIGURE_EXTRA_FLAGS += --enable-adept --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+
+# Enable us to locate the old libept-trinity library and includes
+CPPFLAGS += -I/opt/trinity/include
+LDFLAGS += -L/opt/trinity/lib -lept
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+# Store build information
+common-binary-post-install-arch common-binary-post-install-indep::