summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kchmviewer/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/applications/kchmviewer/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/kchmviewer/debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/ubuntu/maverick/applications/kchmviewer/debian/rules b/ubuntu/maverick/applications/kchmviewer/debian/rules
index a496effa9..c22afc5a3 100755
--- a/ubuntu/maverick/applications/kchmviewer/debian/rules
+++ b/ubuntu/maverick/applications/kchmviewer/debian/rules
@@ -16,6 +16,9 @@ DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -114,7 +117,7 @@ binary-arch: build install
dh_shlibdeps
dh_gencontrol
dh_md5sums
- dh_builddeb
+ dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install