summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kftpgrabber/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/applications/kftpgrabber/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/kftpgrabber/debian/rules48
1 files changed, 0 insertions, 48 deletions
diff --git a/ubuntu/maverick/applications/kftpgrabber/debian/rules b/ubuntu/maverick/applications/kftpgrabber/debian/rules
deleted file mode 100755
index b7b5591da..000000000
--- a/ubuntu/maverick/applications/kftpgrabber/debian/rules
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include debian/cdbs/kde.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include /usr/share/cdbs/1/rules/utils.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- dh_testdir
-
- # Regenerate build system
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- autoreconf --install && automake -f && \
- $(MAKE) -f admin/Makefile.common && \
- touch debian/stamp-bootstrap
-
-build/kftpgrabber-trinity::
- /usr/bin/docbook2x-man debian/kftpgrabber.xml
-
-binary-install/kftpgrabber-trinity::
- install -D -p -m644 debian/kftpgrabber-trinity.lintian-overrides \
- debian/kftpgrabber-trinity/usr/share/lintian/overrides/kftpgrabber-trinity
- mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
-
-clean::
- rm -f kftpgrabber.1
- rm -f translations/*/messages/*.gmo
- rm -f debian/stamp-bootstrap