summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kile/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/applications/kile/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/kile/debian/rules63
1 files changed, 63 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/kile/debian/rules b/ubuntu/maverick/applications/kile/debian/rules
new file mode 100755
index 000000000..2d31b63e0
--- /dev/null
+++ b/ubuntu/maverick/applications/kile/debian/rules
@@ -0,0 +1,63 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_SCRIPT_ENV += LDFLAGS="-Wl,--as-needed"
+DEB_DH_INSTALL_ARGS := --sourcedir=debian/tmp
+DEB_INSTALL_MANPAGES_kile := debian/kile.1
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/kde
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+install/kile-trinity-i18n-br::
+ -for language in `cd translations; ls -1d */`; do \
+ cd $(CURDIR)/$(DEB_BUILDDIR)/translations/$$language; \
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/kile-trinity-i18n-$$language; \
+ done
+
+ cd $(CURDIR)/$(DEB_BUILDDIR)/translations/en_GB/; \
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/kile-trinity-i18n-engb
+
+ cd $(CURDIR)/$(DEB_BUILDDIR)/translations/pt_BR/; \
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/kile-trinity-i18n-ptbr
+
+ cd $(CURDIR)/$(DEB_BUILDDIR)/translations/sr@Latn/;\
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/kile-trinity-i18n-srlatin
+
+ cd $(CURDIR)/$(DEB_BUILDDIR)/translations/zh_CN/; \
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/kile-trinity-i18n-zhcn
+
+install/kile-trinity::
+ # Install pixmap
+ install -D -p -m0644 debian/kile.xpm debian/kile-trinity/opt/trinity/share/pixmaps/kile.xpm
+
+ chmod +x debian/tmp/opt/trinity/share/apps/kile/test/runTests.sh
+
+clean::
+ rm -rf debian/kile-trinity-i18n-*
+
+get-orig-source:
+ @@dh_testdir
+ @@[ -d ../tarballs/. ]
+ @@dpatch-get-origtargz ../tarballs
+